Losing connection to easel

i use xcontroller upgrade. has worked well, but suddenly jobs quit once sent. asked me how it turned out, and green carve button turns blue. If i reset controller or reboot, or refresh browser I can easily get com port recognized again, but it fails again. could this be internet issue>? once job is started is it sent in entirety to controller? I’m thinking maybe not and slow internet could be issue?

No, net access is only required when opening up an Easel-project. Once open not net-access is required.

Search for “RF Noise” / “USB hub” for input.

I have set usb to never sleep and am on a powered hub, per the forum discussions I have read, is there any other steps recommended?

I had this issue when I first built mine. I moved the router power cable out of the drag chain, double checked all the connection blocks in the back of the xconroller, turned off the power saving to the USB port and re-seated the USB cable.

Not sure which but one of those fixed my issue. I’ve not had the issue in a while.

I hope this helps,


Problem is that USB dropout can come from “anything” and it may be hard to locate the culprit.
People have had issues with micro waves, cell phones and fluorescent lighting to name a few. There could be a “dirty” appliance somewhere on the grid you are unaware of.

I am also having the same issue. Is there any way to pick up the carve from where it started or jump forward to pick it up instead of doing carve again?

You can’t start where it left off or jump forward, but there is a trick that can be used depending on where the carve left off. See Phil’s page of tips and look for the video that explains the difference between zero and home. He shows how you can draw a zero depth object over the top of the carve you want to be skipped. Hard to explain but he demonstrates it.


you say that you are only recently experiencing this problem…

The question you should be asking yourself, is “What has changed”??? have you moved things around???, are you using a new/different USB cable??? have you checked your powered USB hub to insure it is in fact working properly???

if it has been working fine for a long period of time…(how long is “has worked well”??) and only recently started acting up, then something has changed. did your computer recently do a software update? sometimes windows updates reset USB settings…

One thing to check is the brushes on the router/spindle. When they wear out they will arch / make sparks which cause a lot of RF noise.

One thing that helped me out a lot is when I ran a second circuit to the machine.
Now I have the spindle and the dust collector and lighting on one circuit and the laptop and controller on the other circuit.

I can’t seem to find the post from Phil you speak of Donnie

thx for the replies. I have had this happen before, but not since upgrade. In this case it appears to be that I had cut depth too deep on first pass, because the resistance was more than normal and it would quit. I don’t understand why, but this seems to be the case. By raising the bit depth per pass the problem has gone away. Interested if anyone has any explanation why this might happen (for curiosities sake). thx again for the replies.

Deeper pass => router has to work harder => more RF noise.

1 Like

Same issue here, found my emergency button had become very loose.
Took front off and carefully reset it and tighten the ring.
What seems to have been happening was the vibration was causing the circuit on the loose button to think it was tripped. That caused the controller to go off, loosing connection with easel, then coming back on.
Seems fine now.

I have this same problem. Head just stops moving. Sometimes Easel asked if it worked, other times it just shows I’ve lost connection to the server. My internet is a bit sketchy in my shop.

It never happens early in a carve. I can’t say for sure, but best guess is ALWAYS somewhere after at least 30-45 minutes into a carve. But I’ve also had it quit 4-5 hours into a 7 hour carve.

My PC never sleeps, never turns off the hard drive, no power savings on the USB.

I saw the comment about removing the router power cable from the drag chain. Cute. How on earth shall I do that? Just stand there and hold the power cable for hours at a time? Why give me a drag chain and put in the instructions to put the power cable in there, only say take it out.

Tech support also told me to do that. As well as put the controller on its own circuit. It already is as I to run a new leg over to the machine to plug it in at all. But can everyone just run a new drop in their location?

ARGH. This is beyond frustrating.

To make matters worse, I’ve found a couple threads about using UGS but I can’t figure out how to get that actually working.

I don’t need software to create tool paths, I need something that can drive the X-Carve without needing the internet and that doesn’t just flake out at random times. And there’s no log file to even look into to see what happened. What is that about? A great way to have no idea what went wrong so there won’t be any interest in fixing it.

I love my X-Carve!!! I make money using it and it’s a great product. But this software is a joke. And now it’s cost me ANOTHER 26x26 joined walnut slab that takes two days just to make.

If I can find anything else to drive this baby, I’ll be gone and never look back.

1 Like

I feel your pain.

  • Easel only require internet access at start-up and file loading / saving.
  • For carving internet is not a requirement (A local (PC) Easel driver is doing that job)
  • Drag chain / power cable, for trouble-shooting that is the way to go. It isnt suggested as a permanent solution, yet.
  • Do you have an externally powered USB hub in use?
  • A good quallity shielded USB cable may also help
  • For kicks, realize that USB drop-out dont have to stem from your Xcarve at all - it can also be caused by in-house lighting, appliances etc.
  • UGS may or may not provide a solution as it is also USB-based

USB connected straight to the PC.

I can only remove the power cord from the drag chain along the Y axis. It has to stay in the X axis. But I’m going to try it.

Although, if the problem persists with UGS, that would sure narrow it down to USB.

Now I want to do it just for the troubleshooting value.

Well I think I’m going to call this solved. I’ve now switched to UGS and have had no issues of any kind.

Since my last post 11 days ago, Easel had become so unstable I couldn’t get through ANY job. Not always erroring out in exactly the same way each time, but the end result is the same: stops part way through the job. Sometimes it asks if it came out ok, sometimes it doesn’t.

The only help support offered was to say there is interference in the USB line or in the power line to the controller and to put it on a different circuit (which it already was).

Also, in Easel when using the zero probe, it carves about .1" too deep when carving all the way through, and .2" too deep if you carve part way; like a pocket.

UGS carves everything correctly. Every time. No errors. No stopping part way through. It shows current job duration AND estimated time left. Visualizer shows tool location during the carve.

Once you set the zero points, you can move the cutter around all you like. Just click the return to zero button and it goes right back to where you set the zero point. In all three axes. This includes AFTER the job is done.

So, you carved your first piece. Wouldn’t it be nice if you could move the head out of the way to get to the clamp under it, change work pieces, then just click return to zero and it goes back where it’s supposed to? No counting clicks or doing another z probe.

Easel worked great for me, until it didn’t. It was especially useful when I was first starting out as there was already MUCH to learn about carving.

But now that I’m six months into carving, UGS is awesome and Easel has outlived its usefulness. If you are looking for an offline solution or a more stable way to send jobs to the controller, UGS is absolutely wonderful to work with.