Losing Z-Axis height

This problem has been there since I put this together. If I’m carving 3D, 2D etc… everything works exactly as perfect as it should.

However, if I do anything that has a lot of Z-Axis movements, such as V Carving (Using Aspire) the Z-Axis will get higher and higher. I’ve tried lowering the speed to 100 mm to no avail.

I was carving a Lady Liberty coin today using V-Carve and less than half way through the Z-Axis was almost 3 mm higher than it thought it was, I have a big heat sink on the shield with Artic Silver, however no fan. The heat sink was warm as was the stepper on the Z-Axis.

Does this sound like a heat related issue? I did some searching and it seemed the Z Axis would go deeper and deeper if there was a missed step or heat issue, mine is getting higher and higher.

Any ideas?

V-Carving with Aspire results in many deep plunges with a v-bit, and depending on flex in your spoil board, speed of your spindle, sharpness of your bit, may be slipping the bit/router/clamp up when it can’t complete a deep cut. Loosing steps when trying to go down. The stepper thinks it has made the cut, but now Z-=0 is just a little higher. Etc…


Hi @JohnI_Kristiansen, please see this link. I had the same problem and was able to fix it. I think the pot for your stepper motor needs adjusted,

Please check to make sure the fan is blowing down on the chips and not up away from the chips on the gshield.

Also check that your bit is tight and not moving in the collet. That can happen.

Try adjusting the current with the potentiometer on the gshield. Increasing then current helps the stepper maintain torque.

If none of that helps then type $$ into Universal G Code sender and let’s take a look at your settings.