Lost connection with Xcarve Error code 31

hello, I tried all the solution above, but still the xcarve lost the connection during the job, never at the spot.
PORT ERROR: Writing to COM port (GetOverlappedResult): Unknown error code 31.

  • Change USB port (I tried 5 different port (USB2, 3, 3.1).
  • turn USB port spleeping mode to disable
  • Used different Gcode sender (easel, open build, transfer).
  • change USB cable

To date, the issues is still present and I can’t run the job.
Could it be the arc generated by the drawing?

there is a similar error 31 in OpenBuilds thread on the OpenBuilds Forum over there: error code 31 | OpenBuilds

the solution in that case was to move the laptop itself away from the EMI source.

Here’s a list of the grbl error codes and their meanings for future reference

Code Message Description
1 Expected command letter G-code words consist of a letter and a value. Letter was not found.
2 Bad number format Missing the expected G-code word value or numeric value format is not valid.
3 Invalid statement Grbl ‘$’ system command was not recognized or supported.
4 Value < 0 Negative value received for an expected positive value.
5 Setting disabled Homing cycle failure. Homing is not enabled via settings.
6 Value < 3 usec Minimum step pulse time must be greater than 3usec.
7 EEPROM read fail. Using defaults An EEPROM read failed. Auto-restoring affected EEPROM to default values.
8 Not idle Grbl ‘$’ command cannot be used unless Grbl is IDLE. Ensures smooth operation during a job.
9 G-code lock G-code commands are locked out during alarm or jog state.
10 Homing not enabled Soft limits cannot be enabled without homing also enabled.
11 Line overflow Max characters per line exceeded. Received command line was not executed.
12 Step rate > 30kHz Grbl ‘$’ setting value cause the step rate to exceed the maximum supported.
13 Check Door Safety door detected as opened and door state initiated.
14 Line length exceeded Build info or startup line exceeded EEPROM line length limit. Line not stored.
15 Travel exceeded Jog target exceeds machine travel. Jog command has been ignored.
16 Invalid jog command Jog command has no ‘=’ or contains prohibited g-code.
17 Setting disabled Laser mode requires PWM output.
20 Unsupported command Unsupported or invalid g-code command found in block.
21 Modal group violation More than one g-code command from same modal group found in block.
22 Undefined feed rate Feed rate has not yet been set or is undefined.
23 Invalid gcode ID:23 G-code command in block requires an integer value.
24 Invalid gcode ID:24 More than one g-code command that requires axis words found in block.
25 Invalid gcode ID:25 Repeated g-code word found in block.
26 Invalid gcode ID:26 No axis words found in block for g-code command or current modal state which requires them.
27 Invalid gcode ID:27 Line number value is invalid.
28 Invalid gcode ID:28 G-code command is missing a required value word.
29 Invalid gcode ID:29 G59.x work coordinate systems are not supported.
30 Invalid gcode ID:30 G53 only allowed with G0 and G1 motion modes.
31 Invalid gcode ID:31 Axis words found in block when no command or current modal state uses them.
32 Invalid gcode ID:32 G2 and G3 arcs require at least one in-plane axis word.
33 Invalid gcode ID:33 Motion command target is invalid.
34 Invalid gcode ID:34 Arc radius value is invalid.
35 Invalid gcode ID:35 G2 and G3 arcs require at least one in-plane offset word.
36 Invalid gcode ID:36 Unused value words found in block.
37 Invalid gcode ID:37 G43.1 dynamic tool length offset is not assigned to configured tool length axis.
38 Invalid gcode ID:38 Tool number greater than max supported value.

Thanks, I just bought another USB cord, and (cross finger) no more problem. Brand new USB are not equal apparently. The USB need to be as short as possible and got a ferite bulb at one end. The one provided with the Xcarve was apparently of very poor quality.

1 Like