Mac now won't connect to Upgraded X-controller

Last weekend, I used the x-carve (older versions from 2016) from my mac book pro, and then I upgraded the xcarve this weekend to the latest x controller etc. But now my Mac won’t even connect to the device at all. I have trawled through the forum and can’t seem to find any solutions. Please help. Ofcourse, it’s the weekend and the support line is only mon-fri.

Here’s what I know…

The Emergency stop button is not pressed down. All the little green lights are on.
I have tripled checked the inside for connection etc, or something I may have missed. All is correct.
My mac is running the latest version of the Easel drivers. 0.3.3.
I have run the set up in both Safari and Chrome, both just sit at the “Connect your USB to the x-carve” window.
I have restarted the machine several times. I’m running, OSX 10.10.5.

Please help. It took me ages to get the first one working due to belt issues and a still unexplainable issue with the x-gantry and being sent wrong bolts from Inventables. I know I know “Welcome to the x-carve” but I wish the front page said something like, please exchange $1600 of your money for many heads aches and “maybe” a system that will work great eventually, maybe!

Obviously frustrated.

Any help would be great. Many thanks in advance.

btw… [jokingly] I’m beginning to think all the youtube videos of people using x-carves to make things are just paid actors, and well done CGI effects.

1 Like

Welcome back Mark, it has been a while. You of course would think of CGI for the videos :slight_smile:

Some people have had issues with the USB plug on the X-Controller panel. Try bypassing the USB port by plugging a cable directly into the board inside the case and bypass the the one on the case.

Hey Erik, thanks, I will go and try that right now!

The best bit about this forum is that moment where you get a tip and you rush off to try it…

The worst part is… well, let’s see if it works first… stand by…


Did you download the driver for the x controller?

Unfortunately, it didn’t solve it…

Curiously, when the x-controller is turned on, I can still push the x-gantry back and forth with a little force, where as before, I couldn’t move that sucker if I tried (pre upgrade)… Not sure if that points to anything connected, but thought I would add in.

I do get the grunt when I turn on the x controller from the motors as before.

But still not connecting.

I wish I could help, I have no experience with the Mac…does the Mac need the FTDI drivers as @DavidAnnetta said above?

Hey David I did not specifically download that, so I took a look.

Was hoping it would be a double-click kind of install but it seems I need to type a bunch of gobble-de-gook to make it work. Not being computer savy that way I will need to work it out (a bit slower than those who are more coding based) but I will try shortly.

I didn’t have to do all this before for the previous version, and the upgrade instructions don’t mention any of this. Oh well… thanks for the suggestion I will try to install and feedback when I know.


Hey David, so I had the drivers installed and nothing has changed. My mac and my x-carve still do not connect.

Call inventables is all I got left.

Okay… so I called Inventables and asked them to help.

I run a mac with 10.10 and everything worked fine prior to the upgrade.

Basically, the support team uninstalled, reinstalled the drivers and tried everything else they could think of, no change. They shipped me a new x-controller, no change. They had the software engineers take a look, no change.

It would seem that for an unknown reason, 10.10 on macs in some hardware setups does not speak to the x-controller, even though it can see it on the USB list. Even though the website says 10.10 is supported, it seems that it is not always the case. You can have all the drivers installed correctly but it doesn’t help one bit.

Inventables did not give up there. They have come up with a solution which I’m hoping to try this week and I will report back if successful.

Thanks all for the forum help, great to sound the issue out to you all first, and even better to have the support team at Inventables to go to as a second option!

1 Like

Dear Forum

I can now report a solution to the problem. The Inventables crew cracked the issue I was having using a Mac with 10.10. Not everyone was having this issue, but those that were were left scratching our heads.

Enter John Hayes at customer support at Inventables…

Basically, the issue was coming from the Wacom drivers installed on my mac which obviously not everyone would have. There is a specific file called:


Once deleted, you have to do a full restart and the connection back to the x-controller worked perfectly.

John and his team figured this out after a marketing person had a similar issue and he thought it might be what was affecting me.

A huge thanks to the inventables support crew for their help. Now all I need to do is flatten my waste board as I’m getting an obvious difference in heights from one corner to the next but that’s a whole separate issue for another day!

Off to carve.


1 Like

It’s interesting that the Wacom drivers would effect this. Thanks for reporting back. Good to know.

I’m going through the same issues with mac 10.10.5 and 10.9.5. my machine is brand new and i jogged it once and now nothing will connect.

Hey Joe,

Did you look for the file I mentioned above?

Also, make sure you have all the right drivers installed, I think someone noted them above as well.

Finally, I do recommend calling the support number and having them look in to your mac.

A solution won’t be far from there.


Thanks for the help! everything is working now they sent me a new x controller board and i bought a new windows computer that I’m going to use only for the x carve. i have so many programs on my mac that could have been creating a problem that this was just the fastest solution.

1 Like

That’s great Joe, pleased you have it working…

Thank you SO MUCH @MarkBreakspear !!! Have been at this all day. Tried different drivers, clearing smc, symlinks for case-sensitivity, perms update (even 777 at one point), browser access, system logs + iris logs + browser console logs, and more… Turns out that damn file was the issue.

I am having this same issue but do not have WACOM on my MacBook pro. Any other thoughts? Ive triple checked everything else and cannot figure it out.

Hey Ryan, what else do you have plugged in to your mac book pro? The stupid mac connectors that mean you need to buy an extra USB dongle are 90% shitcakes, so I found that they are sometimes an issue. Starting at the x-controller, check or replace the cable, then the dongle, then unplug all other USB devices and kill them in the activity monitor. Also check you have the latest drivers. Download them again, to be sure.

Failing that (like me) call Inventables and have them log in to your machine and help hunt down the issue. They did this with me and were great help. Ultimately this was the way I solved this.