Mach 3 help

hey guys and gals, im looking into setting up my xcarve with mach 3. Im trying to find resources regarding setting that up, can anyone help me out?

I assume you’re using something like a Gecko control board for your electronics package, and not the grbl/gshield that the X-Carve is typically configured with? If that’s the case, I think the important numbers you’re going to need are the pulley/belt steps per mm. I think there’s a thread with those numbers on it, let me see what I can dig up.

Thanks for the reply, i have the grbl setup. It seems like its not really compatible with mach 3, am i right?

That’s correct, grbl isn’t compatible with Mach 3. You might check out Universal Gcode Sender (UGS) or Chilipeppr ( which provide experiences more similar to Mach 3.

I could never get UGS to work, every time i open it the command window starts to open and then it just shuts down. I used chilipeppr for awhile but it just messed up one of my jobs because the internet dropped the connection. So now I’m looking at offline solutions, im messing with grbl controller as we speak, trying to get her setup. Any thoughts on why UGS is behaving as such?

If you’re on Windows, you can open a command prompt, navigate to the directory that has the UGS start.bat file (I don’t think that’s exactly what it’s called, but it’s close), and run the batch file from the command line. That way you can see what the error was.

Best guess is that you don’t have java installed, or don’t have it on your path, so it can’t find java.exe.

Thanks for all your help, Ill look into it

I have found that version 2.0 of UGS runs much better. Version 1.8 would not even open on my PC.

me and afew of the guys are planning or have already converted our XCarves to use LinuxCNC/MachineKit . it is very similar to Mach3 but free and opensource. its not for the faint of heart but neither is Mach3. you will have to do some substantial upgrades including a new driver board (Arduino+GShield replacement) and stepper drivers (Gshield replacement)

the upgrade gives you much more flexability of the xcarve machine its self as well as alot more features but its not a turn key operation and will require quite abit of knowledge,help, and effort.

also of note LinuxCNC/MachineKit/Mach3 do NOT support USB you must use a parallel port supported board.

Joshua, once ChiliPeppr is loaded into your browser it doesn’t rely on your Internet connection. So a job could never fail due to Internet connectivity dropping. ChiliPeppr talks locally to your Serial Port JSON Server from the browser. In essence, ChiliPeppr is running as a local desktop app just like every other app out there. The Internet is only needed for the loading part. Is it possible something else happened that ruined your job?

I thought Mach 3 required a parallel port interface. I doubt it would work with GRBL. If you want a good deal on a parallel breakout board along with three stepper drivers let me know. I upgraded to Gecko and have two full systems lying around doing nothing.

I am in the process of acquiring the bits and pieces to convert my machine over to Mach 3.

I use Mach 3 on my BlackTooth laser and I prefer it to UGS or Chillipeppr.

I intend to use the GRBL shield by making a false Arduino board with connections to a breakout board.

On my Laser I use an Ethernet Smooth Stepper ( connected to a breakout board. Driving directly from a parallel port is not recommended these days. The Ethernet Smooth Stepper supports up to three parallel ports, so I am adding a second breakout board to drive X-Carve.

So the chain will be Mach3 —> Ethernet —> Ethernet Smooth Stepper —> parallel cable —> breakout board —> individual cables —> false arduino —> grbl shield —> X-Carve

Obviously I won’t be able to use both machines at the same time, but that’s not an issue for me.

The false arduino board will basically be a set of pin headers in the right positions with cables back to the breakout board. I figure since I have paid for the grbl shield, I might as well use it.

Probably a couple of weeks away before it is up and running.

1 Like

I started my CNC odyssey at with the “book machine.” Learned a lot. I’m glad this hobby is moving past parallel ports - they are getting harder to come by.


Is it a Geckodrive G540? If so, how much?

No generic chinese equipment. Works well. But its not gecko.

Does anyone have a configuration file for Mach on the X-Carve, preferably for a Gecko G540?
I planned to run it with LinuxCNC but I’ve found out my PC isn’t up to scratch but I know it works with Mach3
I just want to test out motor movement, I want my X-Carve to DO something!

(It’s a 1000mm version)


Did you ever get a configuration file for the Gecko G540? I am thinking of going the Gecko route but am a little confounded by the set-up and configuration requirements

Tom Hyatt

It’s no different than any other configuration of a machine in Mach 3. Except, you put this file in the root directory of Mach 3:

As for steps per inch and such, my machine is a little different. Maybe someone else can share theirs.

I didn’t end up using Mach 3 but went with Linuxcnc instead.

Hey Guys,
I am a newbie to the whole Mach 3, Arduino, UGC world. I’ve been reading for hours and feel like I am trying to listen to conversations partly in a foreign language. Is there anyone out there that can explain to me in laymans terms how to set up and use the UGC? I’ve got Windows 8, downloaded the latest version of Java, downloaded the zip file for the UGC, extracted the files and tried and tried to run it. I have a 1000 mm x 1000 mm XCarve with NEMA 23 steppers. Runs fine on Easel. But when I close out of Easel and open up the Black DOS-like run command box and try to open the software and jog the machine I get nothing. I’ve even tried downloading earlier versions of the UGC and nothing. I can hear a slight hum come from the machine but that’s it. Not sure if it is not recognizing COM 4 or what?

Thought about scrapping the whole works and trying to control it by upgrading the hardware and using Mach 3 but that is a lot more work, more problems to solve and still not a guarantee it will work. Honestly this was a big waste of money if all I can do is the few functions Easel offers me. The SVG files I’ve tried downloading from Turbocad into Easel are too big for it apparently and it crashes the web page and it freezes up.