Machine is not moving, need GRBL help?

So I’ve had my X-carve for a while now, and recently I ran into some trouble.
My account was deleted, possibly from inactivity, and when I tried setting up the machine on a new account the Y axis motors were reversed and it began trying to spin. I went to flip the wires on the Y1 connection, but this sparked an arc so I quickly shut off the machine. It was too late. The toshiba driver for the Y1 stepper motor was fried, so I ordered the part and took it to a professional to have it replaced. A month has passed since the initial incident, and when I finally got back to the setup none of the motors will respond. Everything starts up correctly and it connects to my laptop just fine. In the machine inspector, I noticed it was in an alarmed state, but even after clearing that with $x it won’t move. I’m tempted to try $h, but if the motors are still reversed (which is weird because they weren’t initially) then I’m afraid it’ll only get worse. Anyone know of any other grbl commands I can try? I have checked the wiring repeatedly and everything looks good.

I might download the Universal G code sender and try just some single line g codes.

https://winder.github.io/ugs_website/

Version 1.0.9 is the stable version .

1 Like

I’ll give that a try, thanks

Not having much luck with the G Code. I’m thinking of taking it back to the shop, so they can see if there is any power making it’s way towards the stepper motors.

You should hear the motors lock up when the x controller is turned on.

Sometimes when I’m looking for a problem, especially a multi pass situation, I don’t
“see” an issue.

Post some pictures of your wiring and let us take a look.

Now that you mention it, they have been awfully quiet. No signs of activity there


This is the circuit board that experienced the driver failure