Machine not cutting correctly anymore?

First thing to look for is the set screws in the pulleys being loose. I use blue loctite on these and they never back out after that. This exact thing happened to me every couple of days until I used the blue loctite. Same symptoms you’re having here were caused by a loose set screw in a pulley(s).

1 Like

Very comprehensive man, thank you very much! I dont know if I will be in the studio today but I will report back when im in there next :smiley:

1 Like

Riiiiggghhttt, very smart! Duley noted, I will drop into the local and grab some :wink:
Thanks mate!

Ok so I have checked everything. Its all tight, nothing lose, no give in on any axis unless I give it a good shove. I feel like its coming from the left stepper or something… Its like an occasional clicking clunking sound?.. Gave the machine a good blow out too in case it was debris.

Heres a video of it playing up. Its very subtle but you can hear the clunk.

Can you try uploading it again or check the link. As I cannot get the link to work.

This looks/sounds very similar to an issue I just had with my X-Carve. Turns out it was a failing 24V Quiet Cut spindle. I dropped in a new spindle and problem solved. Details here.

ok, im convinced its the stepper motors / maybe just the left one…

This is what happened with my last carve. The ‘steps’ on the bottom should be lining up with the ones in the middle, like a second pass type thing. No idea what’s going on…

Ok managed to download the video. Looks like it is the stepper. You can see it stutter in slow motion with the noise you where talking about.

First if you move the gantry by hand make sure it is the same distance from the end of the rail on both sides. Otherwise it could bind. Its unlikely given the video but still worth looking at. It’s best for this reason not to move the gantry by hand on the 1000mm xcarve as there can be a bit of play.

If thats all good then do you have a multimeter or know someone who does? You will need one with a continuity tester(Beeps when it has a complete path) on it. If not get a cheap one that does continuity just don’t go plugging in a cheep one into any high voltage things.

Unplug the wires from the gshield and put one test lead on the top most screw terminal(AKA the one that holds the wire for the motor) and at the same time just wiggle the wire to make sure it is not lose. Then put one test lead on the wire you just unscrewed from the gshield. If it beeps then that wire is fine. Continue this for all the wires. Any wire that does not beep may be broken or not screwed down enough. The vibrations may have undone one of these connectors at some point.

If that fails to find a fault then try changing the wires on the gshield with another axises wires. To make sure it is not a failing stepper motor driver. You could try this first but if your unplugging everything anyway you may as well test the wires.

Ahhh, thanks Goeff!! Do you think this could be causing the misalignment in the picture above. The second pass of the rough carve was way off.

Yeah, I operate the spindle manually. The video above was actually with the spindle turned off.

1 Like

would it perhaps be a coding issue?

I will put the link to the video above again so that anyone else can take a look.

Having a further think it is very unlikely that it is a stepper driver if the other motor is working(I am assuming that you have a 1000mm machine though. if you do have a 500mm xcarve then it may still be the case).

So it is likely to be wiring or something is jamming or you have a bad motor. The sort of issue with the motor is small but over a large area it can cause the other side to jam as well over time which would make it look like an issue with both but only ends up as being one motor.

Its one of those hard things to diagnose as there are multiple factors at play.

So you may have a broken stepper motor but it would be best to rule everything else out first. So if the wiring checks out then i would say give inventables a email and see what they have to say. They should be able to sort you out if it is a bad stepper.

Thanks again Geoff,

I actually have a 500mm machine. Lately I had to have tendon surgery on my foot so I cant get into the studio quite as much but when Im in there next I’ll be sure to check out the wires. The only reason why I thought it could be something to do with the coding is because I dont really know too much about it haha. Also with that last carve the 2nd pass was just so far off I thought, surely missing a few steps couldnt make that much of a difference. But again im very bloody new to this haha.

I just remembered a few months ago I tried changing some of the parameters in Universal Gcode Sender to try and optimise the machine. I was following a thread I found but there is definitely a possibility that I messed something up??

I will try remember what I changed.

ok I was changing the steps per mm

I have not used Universal Gcode Sender. But changing the steps per mm should not cause what I see in the video. The steps per mm could cause the drift in combination with a broken step as it thinks it is in one place but is in fact somewhere entirely different. From the video something is causing it to jam. It cannot do that step.

Its unfortunately a case of trial and error with something like this which unfortunately can take some time to suss out.

Thinking about it then your first bet would be to switch the x and the y wires in the gshield. after doing this run the same test(just remember that x is now y and y is now x :smile:). If it still makes a clicking noise on the same stepper motor then it looks like all is good with the gshield. If it changes then it could be the stepper driver or software(although unlikely).

All the best with your recovery.

1 Like

So I was having the same problem. (Stair step style drifting on my X axis)

I swaped the axis on my controller (Arduino) and that didn’t fix the problem. still wound up with my stair step style cuts like HarryBrown was getting on the X axis. (I was hoping it would just move my stair steps to the Y axis and then I’d have an excuse to go buy an X controller)

So then I swapped the X and Y motor.
This seems to have fixed the problem. looks like the Nema 23 motor on my X axis is bad. What confuses me is that it didn’t make the Y axis start getting unsquare when I moved the motor over. I figured it would translate the stairsteps from my X axis and then move it to my Y axis (although it would be at an angle because only one of the motors on the Y axis would be bad)

Is this because the Y motors only get half as much power? (because it’s split two ways?) maybe the motor is worn out but it only looses steps when it’s getting “all the juice” from the Arduino controller?

Personally I don’t really need to fully understand the problem in order to fix it. I’m just going to buy a new motor and replace this weird one. But I’d apprciate any insight on the issue. The more I learn with this thing the better I get at handling problems faster.

On further inspection It looks like having the motor relocated is still causing drifting, (so now the X axis is slowly becoming unsquare over the course of time. I think I’ll try one more cut at a slow rate. (like 25IPM) and see if I still have the innaccuracy drifting in the same way.

Regardless, the error is following the motor, wherever I place it, so its getting replaced.