Machine randomly drills into waste board and heads towards top right corner

So I’ve been carving routinely for the last couple of years without too many issues. But I have an odd random problem.

Twice today and once back in November it decides randomly to head towards to upper right corner and drilling down.
The first two times I hit the stop button fast enough but the last time it did damage to my z-axis :frowning:
What is going on? It isn’t slipping it’s driving top speed to a coordinate. Everything is tight. The voltage is set perfectly, motors sound terrific and they weren’t hot at all.

It seems like bad gcode but I don’t know how that could be. Today I was installing a new waste board so it was just leveling it out so the design is simple. Running from Easel on a mac.

This was the second pass. Bit was brand new and sharp and just went thru my brand new waste board :frowning:


1 Like

If you can share the easel project that might help identify the issue.

Also, what are the cncs grbl settings?

I know availability can be an issue in different regions, but particle board doesn’t make the best wasteboard, MDF would work much better if that’s an option where you are.

1 Like

If it is not the design, it would most likely be some form of interference. Have you moved any wiring lately or added anything to the wall outlet circuit that could be introducing noise into the system. Or, have you by chance added a new shop heater close by?


Brandon Parker

1 Like

There really isn’t anything to interfere. My machine is basically in a concrete room by itself and my computer. It has a dedicated breaker.
However, one thing that makes me agree with the interference idea is all 3 axis change direction at the same time.
I have since reran this and it finished without issue. The next problem is I’m going to chuck expensive wood into this machine next week and it can’t fail. If it does I will have to go rent a cnc.

1 Like

Here is my project: Easel - CNC BED LEVEL

1 Like

Another note. I addition to the motors going crazy I’ve had two other jobs today just stop in the middle . I can still press the pause and start buttons on the page but they don’t do anything. Fortunately what I’m doing is simple and I can just start over. Easel doesn’t seem to remember where I set the origin if that is a clue. I’m still stumped.

Yeah, nothing strange at all with that project…it’s such a square… :joy:

Sounds like some type of interference/noise to me. If it stops in the middle again, you can power cycle the controller, rehome the machine, and then use the last X, Y, and Z Home positions for the stock. Those should be saved into EEPROM as offsets from the machine home position from the previous carve; telling Easel to use the last home positions just informs GRBL to use the previously stored offsets.


Brandon Parker


Here are my suggestions:

Remake the file.

Restart easel.

Unplug and plug back in the machine.

Make sure the bit isn’t loose in the router.

If it is loose, make sure the spindle isn’t cracked (i.e. Cracked spindle)

Also, when I opened your file the cut settings were extremely high… it says your feed rate is 245.7in/min and your depth per pass is 0.27559in. If these are your actual settings then I’d bet it’s the problem. Looks like the total depth of the square you’re cutting is only 0.119in so maybe the machine is confused by the cut settings being larger than the actual cut?
When I level mine I use a 0.75in bit at 125in/min and depth per pass of 0.05in.

I just noticed that you said the error occurred in the second pass. When I ran the cut simulation for your carve it only shows one pass. Makes me think it’s definitely the cut settings being deeper than the carve (deeper than you material thickness also).

If that’s not the issue and if the bit is not loosening and falling down mid carve, id try unplugging the homing switches and manually setting the home location for a carve.

Like others said, interference is also possible. Unplug and remove all other electronics from the room. Plug the xcarve into a different outlet if you can.

That’s pretty much all I can think of. Good luck!

Definitely remake the file. I’ve had something like that happen before but not in the second pass. I had a small dot that I couldn’t see on the file and it kept going to it to try and carve it.

Let me start over a bit. Here is a summary:
1.1 Suddenly mid carve the path drives towards the top right corner and down somewhere off the map.
1.2 The problem is the coordinates it is going to are under my waste board somewhere.
1.3 It always fails mid carve. It isn’t near the beginning or the end.
1.4 Twice so far the machine has randomly stopped cutting mid carve. The browser is non responsive and I have to emergency stop via the x-controller and refresh my browser. I think this is related but not sure.
1.5 Occasionally it finishes the whole path without issues.

Here are the clues:
2.1 My router is cutting well.
2.2 My main bits are a 3/4" straight cutter and a 1" waste board cutter.
2.3 My feed rate is good. It cuts quietly without jittering. I’m not sure what Luke was seeing.
2.4 This has happened once with my Aspire post processor and not the Easel drivers. This is when I am using my Windows laptop. Probably because someone is borrowing my mac.
2.5 The axis motors are not hot.
2.6 It doesn’t seem to start doing this after any specific time. My mac is setup to stay awake.

Possible solutions
3.1 This makes me think maybe its a hardware issue.
3.1.1 Usb cable maybe? I’ve tried two.
3.1.2 X-controller Issue ← this worries me. I see others RMA their x-controller for similar issues.
3.2 Or, maybe an artifact in the file somewhere or it is being produced in the file somewhere.
3.2.1 If that was the case wouldn’t it fail in the same place each time?

What I’m going to try:
4.1 I’m exercising the machine without a bit to see if I can reproduce.
4.2 My z-axis is borked up now. I’m going to have to replace it. If we can get to root cause on the issue I’d go ahead and buy the z-axis / motor upgrade. If we can’t figure this out I’m selling the machine and starting over with another. I can’t afford to ruin materials and/or the machine itself. No pressure :smiley:

@PhilWilson, as mentioned, those feeds/speeds on the file you linked to are too high for the X-Carve. That might be an issue causing the machine to just go off into an undesirable direction and not following what it should be doing. There is no feedback from the steppers to the controller; the controller is always expecting that the stepper motors moved exactly as driven. In the event the loading on the tool is too high, the motors can loose steps (i.e. not travel or unable to travel in a direction as they should have and were driven by the controller).

As far as the stopping in the middle of a carve, this is either a computer issue where the USB interface is being put to sleep, or it is a noise issue which could be on the USB side. It is most likely being introduced from the machine side into the controller if you are using a quality USB cable and have it routed away from power cables. One thing that you can do to eliminate noise is to take the shield/drain from each of the stepper cables (you may have to cut back some sheathing), tie them all together, and then connect them to a GND on the X-Controller. If the noise is coming in from the stepper cables, this should help reduced that.

I would be willing to get on a Zoom, MS Teams, or Discord chat with you if you want to walk through what is going on.

Don’t give up on it!


Brandon Parker

@PhilWilson, I’m the Director of Marketing from Inventables! Thanks for sharing this issue. Please reach out to and a member of our Customer Success team will help you resolve this.

I am interested by this issue and what the final resolution is, please share it once you identify it, thanks! In my opinion based on my 5+ years using my X-carve, You are pushing the machine WAY too hard and reducing both the feed rates and the depth per pas will likely resolve your issue. I have Never run my machine any faster than 50-70 inches per minute, .06 depth, as I cut primarily all hardwoods, but I still think pushing these so high causes the machine to lose it’s place and go nuts. I would trust the Inventables team with the issue as I do not claim to have your answer. Best of luck with this!

I didn’t have that particular issue but did have my machine every once in awhile just start diving into the project. I ended up grounding the chassis, installing ferrite chokes on all stepper motor wiring and a powered USB. (I also quit using Easel but that’s a different story)!

I will bet it is electrical/EMC interference. You say you have been running this unit for several years, have you changed the brushes in the motor? Old/worn brushes will cause more electrical noise. IF the router and the X-controller are plugged into the same circuit the electrical noise from the router motor will interfere with the X-controller. I had the same thing happen to me - while leveling the waste board, I too had been using for about a year without an issue, then all of a sudden it couldn’t do a simple leveling cut. Plugged the X-controller into a filtered UPS from a computer system and the issue was solved. Have been using for a long time without an issue.

Welcome to Easel.

It’s not bad G-Code. Where I noticed it consistently happens is when the stupid machine just stops midway through carve. Doesn’t end the carve early and ask how it tuns out - which is a different problem people encounter. This just stops and dwells, program ends like it never happened. When you open up the machine jog dialogue to raise the bit out of the work, it tells you machine must be unlocked first.

Then home the machine. Restart the carve, use last coordinates, and it races off and slams into the top right corner.

Run the program again, rezero the WCS, reprobe, stalls in the middle of the program at some other point.

It’s fun. Love it when it happens. Turn a 20 minute program into several hours. It’s why I stopped using Easel as a G-Code sender.

So sorry for the huge delay. I broke my foot so cnc stuff has been on hold.

I Suspect this is a grounding issue or maybe a static issue with my vac. I’m running a wire thru my vacuum and running lots of dry runs. But a watched machine never fails.

I’ll just keep exercising the machine and take careful notes for each run. I’ll let you all know.

I had the same thing with a new x carve pro. The bit actually broke on the removal.