Inventables Community Forum

Machine seup

Easel doesn’t save the machine setup so I have to go through setup on each new project

I use Windows 10, Microsoft Edge and the latest driver

Sorry to bump an old post, but I have the same issue. I think Easel used to save my machine settings (about 3 years ago?) but now every time I open it I have to redo all the Set up your machine steps. Is this the case for everyone or have I missed some step in the process? I only use the free version of easel with the original g-shield + Arduino, not the sexy black box X-controller.

After a bit of exploring, I found out I had grbl 0.9., so I decided to update this. It took about 3 attempts, one user error, one gave me another error, but third time was the charm. (Almost) I got a message saying

Global variables use 1646 bytes (80%) of dynamic memory, leaving 402 bytes for local variables. Maximum is 2048 bytes.
Low memory available, stability problems may occur.

All the same Easel worked when I tried to run an air carve. However, it still doesn’t save my machine settings. Can anyone suggest what to try next? Please? :pray:

I’m also wondering about this. Do you have to got through ALL of the machine set-up from square one every time you want to carve something? I have a Z puck. I 'm actually having to go through the Z procedure twice to get to the point where you can use the puck to find Z zero. Surely this isn’t necessary. What am I missing here? FYI, I am using a Bob’s CNC E4.

I’ve had this same problem from day one. Why doesn’t Easel save my machine settings? I wouldn’t mind it if just confirmed my settings after hitting the Carve button. Am I missing something here? Is there a setting in Easel or my browser that is blocking the settings? Maybe someone from Inventables could chime in and confirm.