Inventables Community Forum

Machine won't move

So I have tried over the last week to get my Shapeoko 2 working but I haven’t made any progress. Last weekend I updated to Universal G-Code Sender 1.0.8 and Grbl 0.9g. I had some issues with my COM port routing so I had to uninstall and reinstall my port drivers, so the port that I am routing to moved from COM 6 to COM 3 (not sure if that is important but I thought that I’d mention it). I had previously been talking about this issue in the following post but it appears to have gone stale. Read through if you need any more background information.

I now can get the Shapeoko to connect to UGS and Easel but I cannot get either of the programs to move the machine. For the sake of ensuring that all connections are closed, I reboot my computer each time that I try another program. When using Easel, I am able to click the green “Carve” button and go through the entire set-up procedure but none of the Jog functions work. Also, I cannot get it to run the program and complete the cut.

It is the same thing with UGS. I connect to the Shapeoko but cannot jog the machine or run the uploaded .cn file. Whenever I run a motion command, the Machine Status in UGS states that the Active State goes from “Idle” to “Queue” and highlights the state in yellow. After that I usually perform a soft reset, which clears the state but does not unlock the machine.

Are there any suggestions or has anyone ever dealt with this before? I’ve read through everything that I can on the Grbl GitHub and the UGS Git Hub but couldn’t find anything that helped.

When you plug in the Arduino does the computer make a noise?

Is the gshield securely on the Arduino?

Are all the wires securely connected with none touching each other?

Yes, the Arduino does connect to the computer. I can access it through the Arduino IDE. None of the wires are touching, crossed, shorted, etc.

I do not hear the steppers initialize like they used to. Don’t really know what that means though.

My next idea what to completely disassemble the electronics and reassemble along with uninstalling all drivers and reflashing Grbl, but that seems a bit too drastic for me.

Again, this all happened when I flashed Grbl 0.9g (initially flashed 0.9i but couldn’t use Easel) and installed 1.8.0 UGS with no change in hardware. It appears to me that this is all software related but I can’t seem to find where.

Nevermind, the steppers do engage, they just don’t make the noise that they use to.

What baud rate are you connecting at in UGS?

In UGS did you type $$ to remove the alarm?

I’m connecting at a baud rate of 115200.

$$ opens the settings, where in the settings do I disable the alarm?

Under “Help” in the “Machine Controls” tab it says that a command of “$X” will disable the Grbl alarm lock but that has no effect.

id re-flash the arduino. it took me 5 mins to flash so isnt difficult.

Reflashed with 0.9g…no change.

And just to make sure that I am getting the correct HEX, I did the follwing…

I scrolled down to the archive section, right clicked and selected “Save As…” on “Grbl v0.9g Atmega328p 16mhz 115200baud with ShapeOko2 defaults”. I then used XLoader connected to COM3 with a Baud Rate of 115200 to flash to the Arduino and opened up UGS to confirm that it could connect and verified what version was flashed.

Hmm thats super weird man.

@BryanCochran I’ve never seen a situation like this before. It’s hard to tell what is going on. Try using the new Easel Setup walk through we launched on Friday. See if that gets it going.

Well that has been my luck over the past few years; I get something new and find some odd/exotic way to make it not work.

I’ll give that a try when I get home tonight. Thanks to you both for your help and patience.

Also, which versions of Grbl does this support? I was able to get 0.9i to work with UGS back before this issue started. I’d also like to play around with versions to see if there is a different one that works also.

Hi Bryan,

Sorry for the trouble. It sounds like your machine has homing enabled on it. Do you have limit switches installed on your machine? If not, you have to disable homing. In UGS using the $$ command will list all the settings, you can find the one that says homing enabled and set it to 0 (do this by typing $22=0, I believe $22 is the correct register but you can tell by listing all the settings and finding the number that says homing enabled).

Can you give that a try and let me know if it helps?

P.S. the Easel setup will handle this for you automatically in about a day, we are putting the finishing touches on homing enable/disable now.

I do not have the switches installed yet though I plan on installing them once the machine is working. That makes a lot of sense. I will try that when I get home later tonight.

Yeah, all settings related to homing were already at 0. I did flash back to 0.9i and the machine worked as it did before with all of the jog commands working in UGS. I still have no idea why 0.9g will not work. Is the new Easel App going to support 0.9i?

Yup we released 0.9i support yesterday! :sunglasses:

I was problems with my shapeoko 2 not moving either. I updated my adobe flash player and went with 0.9i and it solved the problem.

Hmmm well Easel is not flashed based, so it was probably the upgrade to 0.9i that did it!

@BryanCochran since this is a common problem I want to make sure there is a clear answer. Did you get your machine running?

I updated to GRBL .9i tested with UGS and it connected and worked at 115200 baud on com3 then I tried Easel and went through the Easel setup and all was good then I powered everything down. When I turned it all back on today neither USG or Easel can see the serial port. The X and Y axis lock and nothing can talk to the Ardunio.

I checked the device setting in windows 8.1 and the Arduino shows up under ports, when I checked the setting it showed a baud rate of 9600 so I changed it to 115200, but that made no difference.

The computer beeps when I plug or unplug the USB cable from the Ardunio in so it see that.

Not sure what to try next, maybe uninstall the comm driver and reinstall. I just don’t understand how it was working and now I get nothing.

One important point I learned was having GRBL .8 loaded really confused Easel, nothing moved correctly, I spent hours checking the wiring thinking I must have really messed something up, Then when I finally upgraded to .9i and everything started working I thought I was done, And now I am back to square 0, can’t even talk to the Arduino.

As always, any suggestions will be appreciated.

Note: - The motor connectors on the GRBL shield are terrible, checking the wiring required me to connect and unconnect those little devils 10 or fifteen times. I may buy an X Controller just to avoid those horrible little connectors.