Machine Y-Axis Stuck after Z-Axis going too far

All,

I was attempting to send my gcode using UGS when I must have had something wrong. I am using the Dewalt DW660 setup. The z-axis kept going down (before I had the spindle on) and was stopped (against its will) by the workpiece. It basically used all of the motor’s torque before it stopped the Z-axis came to a stop. I tried to stop the CNC, but it kept going for a couple of seconds before I was able to get it to stop. It was REALLY pressed against the workpiece. I had to unscrew the Dewalt tool holder and remove it to get it out.

I reset it and tested the motion on the X and Z axis and it appears fine, but the Y-axis isn’t moving using the UGS controls and trying to move it by hand also doesn’t seem to be working. Anyone had a similar experience with a milling gone wrong? My limit switches have not been set up yet (I know, I am a dipshit) but I was just testing motion, etc, and going to do a basic test carve.

Any ideas? If I bent this thing and messed it up, you’ll see me on the news punching an ostrich and then throwing hot coffee in its face.

Thanks,
Brian

You can’t move it by hand along the Y even when it’s turned off? Does it look like it really skewed the Y axis so that it jammed? If it still looks relatively straight, you might try backing off the tension on your eccentric nuts and see if you can get it to budge.

Don’t beat yourself up about the switches, they’re just used for homing, and you wouldn’t have had one in the downwards Z direction anyway. I’ve crashed mine on each axis and it’s still working fine, so I imagine this is recoverable :slight_smile:

Brian, I have found UGS to be a bit funny in the inches/metric department you think you are in one and are actually in the other. Thinking you are in inches and really being in metric isn’t so bad things just dont move far.
But going the other way moves things 25.4 times as far as you expected.
I also have found that if you hit soft reset it goes in mm mode but will still show as being in inch mode. To correct this I usually toggle between the two before moving the machine.

If you are using the keyboard to move the axis’s be mindful of the auto keystroke repeat ie; aaaaaaaaaaaaaaaaaaaaaaaaaaaa when you hold the key down, it will apply to moving the machine. Using the buttons in UGS screen does not do this however.
When I zero things out, I set it for small increments in inch mode (0.01 for example) get close with the keyboard then use the mouse and UGS buttons to reach the final position.

BTW if you go the ostrich and coffee route be sure to post video!

@BrianRose - Here are a few things to try. If you can’t move the Y axis by hand even when it is powered down, try removing the motor wires from the wiring harness on both sides of the Y axis, and see if it moves by hand then. If it does, it means you have a short somewhere that is keeping one or both motors from being able to spin freely, most likely at the controller. If not, remove the tension from the belts and see if you can move it by hand then. If that works, you may have a bad motor. If not, it is something mechanically wrong (tweaked or stuck) and you will have to start looking for that issue first visually, and then by taking things apart until it moves again and then whatever you took off last was part of the issue. Let us know how it goes and what you find. Every problem and solution that is shared becomes a learning experience that will help someone else. Good luck!

Thanks for all the help!

I killed all the power, let it sit for a while, came back out and for some reason, it was able to move a little better. I redid the eccentric nuts and tightened one of the Y-axis belts and all was good again. So, disaster averted.

Now, if I can get UGS to quit ruining my projects because they keep switching from mm to inches. May have to find a better solution.

UGS has a nasty habit of switching from to mm to in and vice versa. It always happens when I hit soft reset and I am sure there are other triggers as well. Before I do anything that will result in the machine physically moving I make a point to toggle between the two buttons ending on the scale that I want to work in.
After a while it becomes routine.

I am afraid if the above mentioned similar buggy behaviour of UGS is due to Windows 8.1 os I am using. UGS is never consistent and it doesn’t show machine status at all.

Are there any better alternatives that work with the x-carve? Mach 3? Anyone used Grbl Controller? I am considering purchasing something if it solves some of these issues. Anyone using UGS 2.0.x Beta? I am definitely nervous to use a nightly build if the “stable” version 1.0.8 is what they consider stable.

Check out Chilipeppr at http://chilipeppr.com/grbl It’s got a nice UI and might be a little easier to use than UGS.

Similar issue but somewhat different- my Z axis was driven into the wasteboard also and after getting the spindle and carriage back on the track and re-checking all of the wheels, I can now control the z-axis but it has a constant hum and the z-axis motor is quite hot. I assume I will have to replace the motor but wanted to see if anyone has had a similar issue or know of a troubleshooting technique to check before going with a purchase? Thanks. J.R.

@JeremyHill - Remove the Z-Axis motor, and run it with nothing attached. See if it still gets hot, and hums. If so, try moving it to another axis’ wire and see if it does the same thing there. If it does, it is DEFINITELY the motor. If not, you have another problem and can troubleshoot other variables. Good luck, and let us know what you find.

Thanks. I will give your recommendations a try this weekend.

-I removed the Z- axis and ran it with nothing attached- no change- still humming and hot
-I removed the Z-axis motor and left the wires disconnected. I set the X-axis gantry wiring to the Z-axis wiring set up to check another motor on the Z-axis. The problem moved to the X-axis motor and it was humming/heating up.
-I moved the Z-axis motor to the X-axis wiring. The motor was humming and getting hot again.

  • When I run Easel set up I continue to get a “Configuring Z axis for ACME” popup that doesn’t clear

I believe I may have an issue with the Z-axis motor and the gshield stepper. The interesting part is that I can get the system to run with easel by going through the carve and manually moving the system. The X and Y movements are pretty harsh/choppy but the Z axis seemed relatively smooth.

Should I just plan on buying another gshield and Nema23 motor?

On a similar subject but not quite- I have attempted to use grbl 09g hex in the arduino and get no movement whatsoever. I can return to the 9i hex and regain the movement but need to figure out how to get 9g working so I can use a laser add on. Thoughts?