Maker slide only tapped at one end :(

Just got my new x carve today and during assembly realized that on one of my y axis makerslides , one end is not tapped so I can’t put screws in for the end plate… Hoping maybe I’ve missed something but this feels like an error on the slide itself. Anyone else had this before I call up for a replacement? Like I said one end is tapped, but the others aren’t.


do you have a tapping set?
Doing it yourself may be the easiest and fastest solution.
Couldn t hurt to get one, always comesin handy

You’ll contact support, they’ll send you another piece, and we’ll all be jealous that you got a free piece of Makerslide that you can easily tap yourself. We’re all going to be watching to see what cool thing you do with it. Call it a win after a slight delay.

1 Like

Thanks all… I realized that I should in fact learn to tap rather than have inventables go to the trouble of sending me a new piece, shipping, import duties etc…

So, a quick trip to Rona, one tapping set, and a 10/32 thread later, I am back in action. For some reason thought the process would be much harder, but there you go! Thanks all for the support and ideas… Stay tuned for the upcoming projects… I work in the visual effects industry so have some pretty crazy plans…

Anyone who is interested, I’m just finishing Suicide Squad so go see it when it comes out in August!



its not hard, but it was a drag when we had to do all of them, as a lot of people did before inventables pre-threaded them.
You tend to cut corners trying to speed the process up, often resulting in a broken tap, which was a small disaster :slight_smile:

But, you only do that one time, if you’re smart! DAMHIKT :slight_smile:

Interesting; it seems Mark and I are assembling our X-Carves at the same time and have encountered the same problem. Mine is the Z-axis makerslide tapped on one side and not the other. And since tapping is no longer officially part of the assembly and the instructions for it have been deleted (at least, I haven’t encountered them) does anyone remember which tap is needed? I suppose I can screw them into the tapped end until I find the match, but that’s so… so… you know, not a good idea.

This is the one I used:

Thank you, Erik. And of course my set is S.A.E. I’m off to Ace.

1 Like

I used the 10/32 thread and it fit perfectly. Hope that helps.

Thanks, Mark, that one I have. Worked for me, too.

Funny, but at first I was annoyed that I was given self-tapping screws and had to buy a tap to “properly” attach the slides to the gantry plates. Now I’ve used that tap so much for other stuff, I feel like a kid with Lego - I can build anything with some aluminum, M5 bolts and that tap.

Thanks all… X carve complete, calibrated and tested. I even made someone’s skin crawl… Not a bad days work… 16 hours in total from start to finish.

1 Like

That’s amazingly good time. Let’s see those first projects now.

The Shapeoko2 had me do all the holes by hand it was part of the fun that was a nice 3 hours cut off the time. The Xcarve was several hours faster to build overall for sure. Glad to hear you got it fixed! Almost think people would rather get a 4’ x 4’ crate and have a fully assembled completed unit show up.

Thanks, all who gave answers; I’m sure others will have need of this information. You must be really going at it, Mark! I reached the point of needing a soldering tool and called it a day. Now heading out to get one.

I was so intimidated by the idea of tapping all the Makerslide (had no previous tapping experience) that I got some scrap aluminum and practiced a few before my X-Carve even arrived. It was still by far the most stressful part of my build. I had one major oops, while the tap was half way in I left the makerslide propped on my table to reach for a paper towel and yup it fell and broke off the tap when it hit the concrete floor. I managed not to panic and make things worse long enough to find out about tap extractors which solved the problem with no damage a day later. Other than that the tapping experience was slow and stressful, but with no problems besides sore palms from applying pressure on the tap while advancing it.

I’ve only attempted milling aluminum once on the X-Carve so far, but eventually when I do that some more I plan to make good use of my new found thread tapping skills.

Hey Fred,

Glad to hear you are making awesome progress… for some, the making of the x-carve is part of the experience… it was for me, but it went faster I suppose only because while waiting for it to arrive I watched every youtube video on assembly. I mean “every”!!! so I was probably focused on the main issues that people have faced.

As a side suggestion, when you come to the waste board assembly, I suggest putting each screw next to the whole first so that you remove the [screw it in][reach for new one] repetition that makes it take so long. I was able to assemble the whole board that way in about 20 minutes. (just the 144 screw bits).

Overall the trickiest part was, for me, the frame underneath the waste board, for some reason my brain was fried and I couldn’t get it right first time. Oh well, all part of the build experience.

The best part was turning it on and seeing everything work, all be it a bit wonky… Definitely do the calibration steps as that took my 50% accurate machine close to 99% accurate in one step.

I know I’m basically brand new to this forum, the x-carve, cnc machines… so thanks to all for the quick responses and helpful feedback.


PS. My wife sad that the x-carve was cheat-woodworking… I made her sleep outside so she could experience “non-cheat” shelter for the night.

1 Like

I think she had to type that, what with his broken arms and all…

Dear X Carvers,

Does anyone have a way to use the x-carve if both your arms are broken and your eyes are nearly swollen shut?

Just asking…