Mandatory Firmware upgrade?

Used my Carvey last week. Tried to use it today only to find out that it wants to upgrade the firmware (and fails to do) at the start of every job. It essentially soft locks at “Starting Upload…” This is currently making the machine useless. Boo!

Anyone else have this issue, or can you point me to a process to upgrade the firmware outside of Easel? Is there information about the Carvey board somewhere? A github location or serial debugging info? Anything info would help.

Thanks for reading.

First off, I was able to revert to the 2.7 Easel driver and it no longer forces a firmware attempt. So my immediate issue is solved. Some more info for future generations:

My Carvey is currently running the gCarvin 1.1.5 Firmware
I was running the 3.1 Easel driver, but that appears to have been causing the issue. I’m now back to version 2.7
I also wasn’t able to manually upgrade the firmware via the advanced machine menu in Easel. It would ask for a .hex file but provide a blank screen of possible options.

There is a version of the original firmware @ https://github.com/inventables/gCarvin and you should be able to manually upload via Arduino. However, it hasn’t been updated since 2015 and will not compile with the latest Arduino (1.6.11) So I’m not sure if new firmware is provided as open source somewhere.

Hopefully this will be fixed by the time Easel 3.1 is pushed out.

Thanks for reading

I ran into the same issue over the weekend, only worse. I upgraded to the latest driver and I too got stuck on the endless “starting upload…” stage.

I downgraded to 2.7, but then the spindle wasn’t able to home (during the homing and calibration phase, it moved all the way to the left, into the wall).

After exchanging a few e-mails w/tech support on Monday, I was told to downgrade to 2.6, and that seems to have resolved things.

gCarvin 1.1.5 is the latest version.