Measurement not matching cut piece

I just did the Clamp Set from the projects library. I set holes width and height at 0.330 and it cut 0.286. I also had groves of 0.220 and it cut 0.156. Finally the Piece was suppose to be 1" and it cut 0.924.

I’ve done the power tuning, I checked the step/mm test, squared the X, Y and Z. Lastly, I’ve measured my bit 0.123.

What calibration am I missing?

I’m using Easel on via Chrome on a Windows 10 PC.

Here’s a bit more about my setup.

Shapeoko that I upgraded to 1000m^2
Nema 23 motors
Universal Quite Spindle

Here’s my UGS $$

Grbl 0.8c [’$’ for help]

$$
$0=40.000 (x, step/mm)
$1=40.000 (y, step/mm)
$2=188.976 (z, step/mm)
$3=30 (step pulse, usec)
$4=250.000 (default feed, mm/min)
$5=250.000 (default seek, mm/min)
$6=188 (step port invert mask, int:10111100)
$7=255 (step idle delay, msec)
$8=25.000 (acceleration, mm/sec^2)
$9=0.050 (junction deviation, mm)
$10=0.100 (arc, mm/segment)
$11=25 (n-arc correction, int)
$12=3 (n-decimals, int)
$13=0 (report inches, bool)
$14=1 (auto start, bool)
$15=0 (invert step enable, bool)
$16=0 (hard limits, bool)
$17=0 (homing cycle, bool)
$18=0 (homing dir invert mask, int:00000000)
$19=25.000 (homing feed, mm/min)
$20=250.000 (homing seek, mm/min)
$21=100 (homing debounce, msec)
$22=1.000 (homing pull-off, mm)
ok

I’m not seeing a ton of other parameters mentioned in other threads. I’m beginning to wonder if my Grbl 0.8 is older? Not sure where to find what version this should be nor the directions to update it if needed.

Ideas?

That’s an old version of Grbl. Probably should upgrade to v0.9j

Did you select whether to cut on the inside, outside, or on the path? Choosing the wrong thing will change the measurement.

By power tuning, do you mean potentiometer adjustment?

For the step/mm test, did you hit the refresh button in Machine Inspector and then reload Easel? The settings may not take effect if you don’t do those.

I didn’t select where to cut, I selected the project from the project library on inventables. I only changed sizes as mentioned. Guess I’ll have to run some tests on dimensions and settings.

Yes, I ment potentiometers adjustment by my comment of power tuning.

I did the step/mm test in easel, not ugs. I set the router to a rule and simply had it move 200mm on X and Y and watched it move 200mm on a few test.

What is machine inspector? That ones new to me.

What version of GRBL works best with Easel?

Since all your measurements were undersized, if it isn’t a line selection issue it could be a loss of steps for some reason or other. Low pots is a common problem, but another very common one is loose or missing pulley screws. If one screw isn’t tightened in the dead center of the flat on the shaft, the shaft may be turning slightly before it engages the screw. The screws can easily work their way out, a lot of people apply a little bit of low- or medium-strength loctite to them.

Another possible problem is improper belt tension. Too high and the steppers lose steps because they require too much torque, too low and the pulley could be slipping past the belt. One good forum thread for mechanical loss of steps is [Guide] Offset cutting, Lost steps, Positioning errors, etc.

You can find Machine Inspector under Machine->Advanced in Easel. The default settings for the step/mm usually seem to be pretty close to accurate, not as far off as the numbers you gave earlier, but it’s something that might be worth looking at. I believe the values you’re looking for are $100, $101, and $102. I know the X and Y for my machine were 40.0 by default, and the Z is dependent on which lead screw you have.

I posted a video on doing the step/mm calibration, it also shows how to get to Machine Inspector: X-Carve Maintenance/Troubleshooting Videos - Add Your Own!. There’s also a video in there showing how I measure belt tension on my machine.

Here: http://lmgtfy.com/?q=grbl

There are instruction in the GRBL github and wiki on how to upgrade the arduino firmware to the latest version.

Thank you. I’m going to start with the GRBL upgrade as I don’t have parameters for 100, 101, 102 etc. GRBL v0.8 only has 0-22.

RobertA_Rieke - Thank you for all the tuning pointers/trouble-shooting and links to resources. I’ll review my wheels, belts, etc. First step I’m going to do after updating my GRBL is run a test project of Inside, Outside, OnPath and Fill so I know what I’m cutting size-wise with each option.

Inventables - This does beg the question - I know for me I would find it extremely useful, if all the tuning/calibration info/resources where located in Easel via a link instead of search and discussing in the Forum. The trouble-shooting screen after a project is canceled in Easel is useful. If there were links to these videos of how to tune/calibrate if would be that much better. Additionally, this information would really helpful if it was part of the setup instructions.

Don’t forget, from v0.8 to 0.9 the connections are different for the z-axis limit switch and a couple others.

look here for the differences:

Wow great point.

Hmm my Arduino and grblshield are Shapeoko v2.

ErikJenkins - looks like one needs to switch D12 & D11. Not sure how I’m going to accomplish that with the grblshield as they are printed into the circuit board. Do I need to buy a new grblshield? Or am I missing something?

I just swapped the wires going to the shield when I went to v0.9j.

I made a new header for all the connections and just plugged that into the shield.

Dang I have header pins on my grblshield and it is stacked on my arduino. But yea your right, guess I could remove the headers and wire it to resolve.

After you’ve upgraded to GRBL v0.9 does one need to change the setting in Easel from Shapeoko to X-Carve? Under the menu option Machine | Machine setting

I don’t use Easel so I can’t answer that question, however, if you upgraded to version 9 from version 8 or before there is a pin change on the Arduino for version 9.

The Z homing switch wire moves from D11 to D12.

D11 becomes the PWM spindle control.

Yes, thank you. I switched D11 and D12 before upgrading to v0.9

I updated to the Grbl 0.9j via the Arduino IDE, then ran UGS ask for a $$ report. Here’s what I got

Grbl 0.9j [’$’ for help]

$$
$0=10 (step pulse, usec)
$1=25 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=0 (dir port invert mask:00000000)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.010 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=25.000 (homing feed, mm/min)
$25=500.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=250.000 (x, step/mm)
$101=250.000 (y, step/mm)
$102=250.000 (z, step/mm)
$110=500.000 (x max rate, mm/min)
$111=500.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=10.000 (x accel, mm/sec^2)
$121=10.000 (y accel, mm/sec^2)
$122=10.000 (z accel, mm/sec^2)
$130=200.000 (x max travel, mm)
$131=200.000 (y max travel, mm)
$132=200.000 (z max travel, mm)
ok
X-carve Grbl Default Settings - 500mm
I took notice of LarryM’s default settings for GRBL and changed what I thought made sense.

So I now have the following GRBL settings

$$
$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=188.947 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=290.000 (x max travel, mm)
$131=290.000 (y max travel, mm)
$132=100.000 (z max travel, mm)
ok

But LarryM’s settings are for a 500mm cutting area. I have a 1000mm^2

Does anyone know the default settings a the 1000mm^2 GRBL?
Or what I should change to have the default settings? Given my last $$ report

$130 and $131 - change to 790.

$3 and $23 are for the wiring as done by Inventables instructions for the stepper motors.

Looking at the machine from the front +X is right, +Y is away, and +Z is up. If your machine moves backwards on any axis you can change that with $3 and $23. Order is ZYX.

Thank you!

I cannot test $3 and $23 right now. I’m in the process of upgrading other parts of the CNC. Stepping up to the Dewalt 611.

If one of the axis move backwards - what do you change $3 and $23 to to address the wrong directions?

Each bit in the parameter is for a particular axis. The order is ZYX.

000 = 0 = no inversion
001 = 1 = invert X
010 = 2 = invert Y
011 = 3 = invert X and Y
100 = 4 = invert Z
etc.