MillRight M3-Z axis travels too far

Hello everybody
I am using the easel driver to run my Millright M3 router. I have selected the M3 option in the “choose my machine” dialog box. X an y travel works fine, however the Z axis travels about double the distance it is programmed to. (for instance a 2mm deep pocket is milled just over 4mm)
I am sure that it is not a hardware issue. When I download the G code and put it into Universal G Code Sender, it works fine. Are there settings somewhere that I can change the z axis step distance in easel?
I am using this with middle school students, and the easel software is SO user friendly, it is awesome for a school setting, and I’d love to stick with it without a work around like setting all the depths at 50%.

It actually is :slight_smile:

Scaling in half/double etc => microstep setting is different. This is adjusted on the Z-driver.
You can also, in software, edit the step/mm to counter the scaling. For Z that is the $102 parameter in GRBL.

Ok, now I see what is going on. Can you tell me what the filepath is to find and fix the correct line of g code in the easel driver? I need $102=80 to set my z axis correctly. Thank you for your help.

I figured it out and its working now. Thank you for your help!

1 Like