Minimum distance to rapid?

I’m using easel to generate gcode for my custom build laser project. Things are going well, I can easily replace the Z up and down with laser on/off commands.

However, I’ve noticed in the saving of the gcode, I am running the whole thing at 200mm/m (my cutting feed rate) and nothing is ever moved on a rapid.

Now the whole thing is under 100mm, with most objects closer than that. But the Easel generated toolpaths do go back and forth across the piece quite a bit, but never moves at a rapid.

Is there a ‘minimum distance’ of a move that Easel considers before using rapids?

Shared file here. I go to Machine > advanced > generate gcode and then save it and do a find/replace on the Zup with M107 (shut off laser) and Zdown with M106 (laser on).

Ok, after further examination - it is issuing a G0 command…so it should rapid. Not an Easel problem.

Does Easel automatically set rapid speed in the firmware somewhere so it knows without having to issue a G0 feed rate on each line?

Can you set a G0 F2000.0 in a gcode file and most controllers will accept it and figure out what to do with it?

I’ll have a look at your project when I get to a computer later Alan, but it could be that it is doing a rapid but being a short distance it isn’t making it to full speed as that is constrained by the configured max rapid speed and importantly the acceleration allowed.

Issue a $$ command in Machine Inspector in Easel to see those numbers.

But yes, in gcode you could issue a rapid at F16000 but it would still be clamped at the max set.



HI Alan,

OK, so line 5 of your gcode shows a rapid to it’s start position after setting Z to safety height. It should rapid to it but as the distance is pretty short it might well be you have the rapid speeds and accelerations too low? I’ll test run your project in a minute when I get out to my shop and post back in a while.

As an aside, line 4 shows you switching the spindle on and to 14,000rpm. I would double check that is giving 100% duty cycle on your PWM signal as my X-Carve (stock unit with 24v spindle) needs a requested 18,000rpm for 100% duty cycle. I think this is all dependent on your machine setup but worth checking if you expect 100% power on your laser.



Thanks Ian.

I use Notepad++ to find/replace the Z movements with laser commands.

So any time it goes G0 Z3.810, I replace with M107 (laser off)
When it goes to something like G0 Z-0.10 I replace with M106 S255 (laser on full)

I can’t seem to load Easel this morning, but I don’t even recall that line in there. Maybe that’s for your machine if you have spindle to auto? I have mine set to manual.

I do see the G0 rapid, but it doesn’t have a speed set, so it doesn’t really “rapid” any.

I was hoping I could just set G0 F2000 (two thousand) at the beginning and any G0 movement would use that feed rate, but it doesn’t appear to. After the G1 movements at F200 (two hundred) …it seems the next G0 would use the 200 instead of the 2000.

I had to go in with notepad and add an F2000 to every G0 line to make it move faster. My gcode sender for Marlin has an estimator, and that moved it from near 40 minutes down to 16 minutes. Haven’t run it to see if it rapids all those really fast or not.

Check out the acceleration speeds for the X and Y. It probably has to do with that. I recently reflashed my Arduino and realized last night that those settings are way off. It takes rounded corners super super slow because of it. Probably doubled my carve time.