Motors not responding

I’ve had a 1000x1000 Xcarve for a few years now. A couple of weeks ago the z-axis motor started having some issues and stopped working and was extremely hot. I thought after a few years of use the motor died and I ordered nema23’s to upgrade.

I went through and replaced all motors with the nema23’s, new wiring and added a new threaded rod while I was at it.

Fired everything up and the z-axis went up and down a couple of inches a few times and then started grinding and struggling.

I honestly got fed up with it and left it for a few days. I tried again and the same exact results. It will work for a moment find then it keeps grinding and not spinning the shaft no matter what.

Here is a video of what happens (

Notes on troubleshooting.
New wires
new motors
I’ve messed with the potentiometer settings, no change
verified wiring is correct. this issue also randomly started without any wiring changes.
No other motors are having issues.
As you can see this still occurs without anything attached to the motor so not an issue with the z gantry

At the beginning of the video, you can hear the noise made by the gshild/Arduino I feel like that’s not normal and I’m thinking one of those may be the cause of my problem, or maybe the power supply?

I’m out of ideas and frankly fed up with the issue at this point.

Any chance you changed your grbl settings?
Can you post those?

Do you have another arduino you can try?

First of all:

  • Take one of the others (known good) steppers and connect it to Z output.
    Does this work okay and consistently?
  • Set microstepping for Z to 1/1 (full step) for the time being, this is only for troubleshooting.
  • Measure reference voltage for each driver
  • What is your $$112 and 122 GRBL parameter?

I’m pretty sure I haven’t touched these but…

here are my settings

I, I had another arduino floating around so I pulled that out and flashed it. Same issue. I’m thinking its the gsheild at this point? I know potentiometers are fairly sensitive and this poor xcarve is now in its 3rd home.

Have you tried this?