Motors ON / Motors OFF

It would be great if we could turn the motors OFF/ON in Easel (or is there a way and I missed it)
I position my tool manually and I have to turn the X-controller off so I can move the motors, and then back on. Just time wasting waiting for connect/disconnect of the USB, and annoying when on occasion it won’t re-connect and I must completely re-boot. If I could simply turn the motors OFF so I can position the tool, then turn them back on like in most 3D printing interfaces - that would be great!.

Thanks for consideration

Moving steppers by hand not a good idea. You’re generating power back to electronics. Suggestion to use jog keys to position your axises. Also helps not to lost zero position for X and Y axis everytime. All you have to do is run one more Z zero after changing your bit.


Thanks for the advice, but unless you move the motors at lighting speeds, it shouldn’t hurt anything. I’ve been moving them for years and never had an issue.

My home can’t always be in the same spot, my Z is never in the same spot depending on the project I am cutting. And using the previous home position only seems to work once. After that if I try to use the previous position a third time it will again raise the bit a second time. Jogging is to slow and a pain, especially when you forget that it is set to 10mm and I hit the down arrow. :frowning:
If I use X and Y homing switches so the X-Y is always in the same location I have to then make my jigs that hold the projects to accommodate that location, not to mention I then need a way to lock it into the machine so Home is in the right spot every time. I don’t need to worry about all that if I can just move the machine by hand.

1 Like

That means you know what you’re doing. My other suggestion is to install F stop to 24 VDC, when you cut the DC power, your steppers will be free, arduino still alive. This time you can turn DC power on after moving both axis to anywhere. You don’t have to reboot whole thing.

1 Like

My e stop is upstrem from ny my 120v power strip , when i cut power it is only to things that move, ie; the steppers and spindle. The arduino is powered from the usb port and stays awake. If i dont pause or cancel the file transfer from ugs, it just keeps on sending happily like there is nothing wrong. but all physical motion stops instantly. I have not even noticed a lag from the capacitors in the power supply.

I understand all of the homing stuff, I have reason for not using them that would take to long to explain here, thanks.
I may try the E-stop thing, I am using the X-Carve controller and the e-stop switch is hooked up the way the instructions say, but that shuts down the entire box, I think. I only hit it once so will try and see.

If I remember right, there is a G-code command turn off the motors.???

You can try M84 it is supposed to disable steppers until next move command

stepper idle delay will automatically turn off the steppers when they are not in use. Not recommended if you need to hold your position while changing bits, but might work for your specific needs.

$1=25 (step idle delay, msec)

Thanks for everyone’s Ideas!

Just tried m84 in ugs.

error: Unsupported command

Bummer that would have been cool