My computer is not picking up the x-carve

I have read much of the discussions on the forum. I have tried many of the suggestions and still am unsuccessful. I reloaded EaselLocal (3.2) and the arduino (1.8) software, reattached the gshield to the arduino, checked Device Manager to find the COM number and it is not showing up. So, my computer is not recognizing the X-Carve and/or Easel. I am new to the cnc and am totally at a loss.

One other thing, when I put the machine together I didn’t wire the limit switches to the control box.

Could someone please give me some advice and maybe walk me through getting up and running. Thanks in advance.


XController or Arduino/Gshield?

Each controller appears as a different device inside of Windows.

If you’re using the XController, you need to search for the FTDI USB drivers to install. The XController has an board USB chip that the Arduino doesn’t have.

Thanks, I have an arduino and gshield. None of them are showing up.

Just a matter of a check, make sure that your ''red panic stop ‘’ button on the x-controller box is fully pulled up. I had the same problem until I realized that my ‘‘red panic stop’’ . However I had to reload Easel from the beginning to finally got it going…

Thanks for the recommendation. I have an older version. I don’t have a Panic button. I got my machine in Aug of 2015 and am just now putting it together. Sorry for any confusion.

Have you tried removing the Gshield and just connected the Arduino only to see if it works?

I removed the gshield from the arduino and the arduino is working but when I put the gshield back on I loose connection. What is my next step to check?

I got the arduino to become recognized but now the gshield is not being recognized. I followed removing the arduino from the housing when it was determined to be working and I put the ghield on the removed arduino and it worked. I then reinstalled the arduino into it’s housing but when I put the gshield back it does connect. I am pretty sure it is fully secured. Any suggestions! I am so frustrated.

The houing is causing some issue. I know when I put mine in the housing it was a TIGHT fit. Make sure that the pins are going in the right socket AND that the card is fully seated into the Arduino.

Thanks to everyone for your responses. I finally got it working with the help of Inventables Support. Thanks Inventables.

Please could you explain the solution that worked for you? I am having the same problem. Thanks.

I’ve fixed the issue by installing an older version of the easel drivers 0.3.2. The most recent version 0.3.3 was the problem. Hope this helps anyone experiencing this problem.

1 Like

Macbook pro (early 2015), OS X Yosemite 10.10.5.

I tried Safari, Chrome and Firefox separately, making sure only one instance of easel was running at any one time. Restarting the laptop, clearing browser data and reinstalling the easel drivers with no luck. I had given up and thought it was a hardware issue on the x-carve. Luckily I found some old forum posts that recommended installing older versions of the easel drivers to fix a similar issue. Once I installed 3.2 I was able to connect straightaway. Just shows how valuable these forums are, so thank you to everyone that contributes.


1 Like

Hi DavidClarke, I’m using Windows 10 and an x-controller, but I might be having the same problem you had, can you tell me where to find the install for easel 3.2?