My mini cnc goes out of workspace while printing

I built a mini cnc machine from dvd parts.
My work base is 30 mm x 40 mm,
my problem is
even if i change the dimension of machine workspace and also the material to under 30 mm x 40 mm and start printing,
the design is very big and the plotter goes out of the workspace…
What shall i do?

Scale your design down to fit within the machine limits.

in the easel editor, i just typed a letter A … within 20mm x 30 mm , still it didnt work… :frowning:

zeroing at lower left corner
arduino + grbl
grbl v0.9a
rod selected 500mm x 500mm

Which is it?

1 Like

You mentioned you built a mini-cnc out of DVD parts, then later you mention X-carve. I believe Justin’s question is which machine do you want help with?

Are both of your machines carving the letter A much too large for the material? Can you take a photo of the machine/material and post it?

The diagonals in the workspace represents two legs of A

Xcarve - MiniCNC(DVD), it’s all the same right?? :wink: Nope.

I would guess that your stepper ratio/multiplier is wrong. Stepper controllers can be adjusted to accommodate that.

how to do it? i am a newbie… can you see the setup image that i posted in this thread and suggest me the changes?

I don’t think easel will work with 3D printing. I could be wrong.

It’s a function of the stepper controller, not Easel. Search this forum for ‘microstep’

If it’s GRBL, you need to calibrate your steps/mm. Your steps/mm will most likely be nowhere close to the Xcarve defaults.

You posted your GRBL settings above, value $1-$3 show steps/mm and you need to recalibrate.

Set pen at your lower left point which is your work zero
Open Easel Carve Button, and type 1mm in the jog window and click the right arrow once.
How much did the pen actually move?

yeah, I see the pen in the pic now :nerd:

1 Like