My X-carve is cutting irregularly

I have encountered a problem that mystifys me. My X-carve is tracking strangely.

I have reworked my project several times and still a problem.

I can duplicate is by doing a simple circle which is cut to a depth (0.2").

As the 1st layer is cut it cuts from the outer circumference working it’s way in. As it works in the cirle moves towards the right. When it strats the 2nd layer it starts in the center and works outward, howver the centre is not in the true center but again displaced to the right (see photo).

Does this with circles, squares, and several simple projects.

There is no binding, everything moves smoothly.

My X-carve uses the standard spindle, and grble electronics.

Anyone else experience a similar problem?

I had something similar and i think it was the belt pulley slipping on the stepper motor shaft. I found that it wasn’t a problem on the first pass but subsequent passes were putting more resistance/force and causing the pulley to slip.

To test: make a mark on the head of the shaft and to the pulley and see if it moves. If it does slip try tightening but be cautious as over tightening can strip the hex drive. Also try cutting a rectangular box in outline mode, cutting outside of the line, and make note of the dimensions to see if there is drift in one direction, Circles and curved lines are hard to tell where the problem lies.

I switched out the little set screws for a socket cap screw as the hex drive is a lot bigger. For a NEMA 23 i used a M3-8mm.

Thanks Kevin, checked, all set screws are tight (checked Z, X, and Y for good measure), screws also locked with Loc-Tite.

Any one with any other suggetions?

Bob, here’s a link for the troubleshooting videos.

I would check out the belt tensioning, adjusting potentiometers, and stepper calibration videos for your issue.

1 Like

My unit is not new. I have run it in properly and have calibrated, worked like a charm for the most part. This current problem is new.

A few days ago I had a problem in positioning in the middle of a job running ArtCam problem and Chilipeppr. Looked like a short power failure stutter. I never totally resolved that one…

After reset and restarts of computer and X-carve now have this problem with Easel.

I guess the best bet will be to reinstall Easel and Easel local and reconfigure my machine as if new and see if problem resolves.

I will report back as I try various things.

1 Like

If you reinstall Easel there are some libraries you have to clear to get a trully fresh install of Easel. ( I am on a mac and if its a PC im not sure what that fully entails) I called inventables help and a quick 5 min call they gave me the steps and what directories to clear before doing a completely clean install. At the time there wasn’t much on the forums for help with a full reinstall.

Thanks, I will give them a call at the 1st of the week for the info.

Seems like you’re losing steps on the X axis, if I understand the problem. It sounds like you’ve checked the most obvious problem with a machine that’s dialed in (M3 setscrews), the next most likely problem in my opinion would be the V-wheels inadvertantly tightening and/or the belt stretching (tension drops, pulley spins). All issues that can happen over time, especially if you don’t check them on a regular basis.

Is this only happening in one area along the X-axis? It’s possible you may have some damaged or missing teeth on your belt, which could cause your pulley to spin for a bit before it gets moving. A quick visual inspection of your X axis belt should tell you if that’s the problem.

Phil, Robert, and Kevin,

Belts are OK, no damage no missing teeth seen. Wheels were OK, although did adjust one one of “X” carriage - a little loose. No binding, all carriages track smoothly.

All geared wheels of stepper motors are tight and fixed with LocTite.

Problem occurs over entire cutting surface, have tried test cuts of a circle over several locations, same result.

Checked pots, all OK.

I reinitialized my “Easel Local”. Reset machine settings through Easel.

Have not reprogrammed my Grble yet, guy at Inventables offered to help me do that next week.

So, having done all the above I retested and the problem remains. See photos below, the test is a simple circle. 1st cut starts at the outside and works into the centre. 2nd cut starts at the center and works out, and you can see that the final cut is shifted a little to the right. The 3rd cut is from outside to center and again you can see the shift again to the right, and the right edge is not cutting one layer, but rather all threelayers at once…

All this is from a machine that was working great to having this recurring problem, any further suggestions will be appreciated.

completion 1st cut

2nd cut

3rd cut

3rd cut from above, note cut is moving to the right.

If everything is tight or as loose as it needs to be and you are getting the issues…try a different USB cable.

Tried cable, no effect.

Have gone back to basics and did a lot of adjusting from zero on wheels, belts, and pots.

Adjusting pots did make a difference. Tried 4 settings for 'X" and with setting at 5:00, increased from “0” and the movement out of register has decreased substantially. Will try a little more adjustment tomorrow and see if I can get rid of it all. The power setting is higher than successfully used in the past, before this current difficulty.

Spent a couple of hours re-setting belts, connections, wheels, pulleys, potentiometers, setup machine again too, reinstalled Easel_local. Am able to improve matters a little (adjustment of potentiometers is only thing that helped, but still can’t eliminate it all. Still not good enough to cut projects.

I’m all out of ideas. Only thing not done is reflash electronics.


Are you using the 300w Quiet Cut spindle? If so, are there a lot of hours on it? I know when I had mine installed after I first got the X-carve, I had about 15-20 hours on it and then it would start losing steps because the spindle was going out and causing too much electrical interference.

Hi Tarry and others who have chimed in on this topic.

Inventables must monitor the forum closely. A rep from them contacted me direct and indicated that I might have a spindle problem if it was the 24v quiet spindle. They got a few more details from me and had me run some printed traces and look like we have a culprit. Looks like I may get a warranty replacement.

Boy, what great service!


Yes, in motion.

1 Like

New Dewalt 611 arrived and changed out the old 24v spindle.
WOW, what a difference! Now cutting correctly, faster, bigger DOC. Will take some getting used to and rethinking my settings, but worth it!

Waiting for precision nut and wrench to go with precision 1/8" collet I ordered so I can use my 1/8 bits. Currently playing with basic cuts using my 1/4" bit.

My thanks to Inventables for the warranty repair.