My X-Carve is up and running! (mostly)

After nearly 3 days of building I finally have my X-Carve up and running!

Remaining issues:

  • Y extrusions appear to be upside down (despite paying close attention to the videos/instructions). Not sure how this happened. The only downside is that the screw that is supposed to hit the Y limit switch is too low. I don’t plan on taking the whole machine apart to flip those 2 extrusions, so I’ll just make a bracket that will hit the Y limit switch.
  • Z limit switch is broken. I’ll need to hunt down a replacement, and then I can setup the machine to auto home.
  • Arduino shield connection point for the limit switches and spindle control is too loose. I’m going to eventually swap this for a better connector.
  • Wiring from the machine to the power supply/arduino is a bit of a mess. It is way too short to be able to move the power supply anywhere convenient, and will make moving the machine nearly impossible with one person as there is not enough slack to let the power supply rest on the platen for moving/storage.

My fist test cut (simple text engraved into wood) turned out wonderful. Only issue was that the bed does not seem to be perfectly level, so the right side of the engraving is slightly shallower. I’m hoping there will be bed leveling instructions released soon, as the easel software does not seem to account for that.

I’m carving a more complex piece out of dual color HDPE now, which will likely take at least an hour or two. So far it’s looking amazing, but the issue with the bed not being perfectly level will be a problem for such a shallow design that is intended to reveal the second color of the HDPE.

2nd carving just failed 30 minutes and 20% in. While writing this post the sound of the machine suddenly changed, which is never a good sign. Looks like the 0.03125in end mill snapped. I’m using the easel default settings for HDPE ( RPM: 18000 RPM, Depth per pass: 0.040 in, Feed Rate: 15 in/min ), cutting the sample piece of 1/4 HDPE that I ordered with the kit at a target depth of only .065", and somehow it still snapped the end mill. Looks like a bit of HDPE caked up on the end mill and increased its width, likely causing some lateral force that snapped it. At least that’s my theory. There was not that much material on the bit that snapped off, and all HDPE was removed with a swipe of my fingernail. May have still been too much buildup for such a fine end mill.

So in addition to needing a new limit switch I now need a new end mill, and some new test material as easel does not have a save function, so I can’t return to this project later and save the material.

While my celebration has been cut short, at least the machine is working!


Hi @ChrisWundram,

Glad you got your machine up and running!

I encountered the same issue with the limit switch/rail orientation. We are going to update the instructions as soon as we can. I’m sorry you ran into that problem.

Easel saves every project automatically. There is no need to ever “save” a project. If you click on the Easel icon in the upper left, the project drawer will slide out, and you’ll have access to every project you’ve ever started. Easel does not, however, currently provide a way to start a job back up at the spot where you left off.


If I am understanding the little issue with limit switch placement, I had the same issue too. I fixed it by just flipping over the limit switch so the lever pointed down and met the screw on the low slot of the rail. Not sure that helps you gents, but thought I would share it anyways…

@DonDespain Thanks! I’ll see if flipping that switch will work, I bet it will!

@JeffTalbot I was not aware it saved automatically. I found what appears to be a save, which is using the name “Intro to Easel” still. I’ve tried renaming it, but that functionality does not appear to work yet.

Few questions:
Any thoughts as to why the brand new end mill would snap so easily with default easel settings and the provided HDPE?
Is there any manufacturer information about the end mills that were provided?
Is there a recommended place to order a replacement limit switch for the one that I have which is broken?

Thanks again!


CNC4PC sells limit switches cheap. I got some for my lathe last year and they weren’t more than 3-4 bucks each for the cheap ones.

What size endmill did you break? The little ones (1/16th and below) are very fragile - you need to find the perfect combination of spindle speed and feed so you are cutting and ejecting chips. And as you get deeper, don’t let the chps build up in the slot because it only takes one little strand to wrap around the bit - it will weld itself there in a split second, the bit will stop cutting, and it will snap.

I broke the 0.03125in one that comes with the X-Carve’s optional end mill set. I was using the easel default settings for HDPE, which I thought would have been well dialed in to prevent buildup. And this cut was super shallow, only going down to .065"

Looks like the fist big project before I can really use the X-Carve will be making a shop vac attachment for it. I was manually clearing everything with a vac, but I guess I was not doing it frequently enough.

That’s 1/32". It doesn’t take much to break them. I see the earlier post you said depth per pass of .04. That does seem a bit deep for a 1/32. If you google around for milling speeds/feeds for hdpe you’ll find some charts and hints.

And have you fixed the uneven table yet? If not then you weren’t cutting .04 consistently and you might have overloaded it when you hit a high spot.

The table is the proper hight on the left side, but lower on the right side, so rather than cutting too deep, it’s cutting too shallow. I’ve not leveled it yet because there do not appear to be any instructions on how to do so.

When I first set it up I placed a sheet of paper on the table and lowered the Z axis until I felt resistance between the paper and the end mill, then moved the X/Y to the 4 corners and checked for spacing. Once I know how to independently adjust the hight of the 4 corners I should be good to go, but that process does not seem very obvious at the moment.

I assumed the feeds/speeds/depths in the easel HDPE preset would be well tuned for the machine and the HDPE they shipped with it. But now I’m out one end mill and one 12x12 piece of HDPE.

“Intro to Easel” is the first project you run after completing your machine setup. You can change it freely and rename the project.

Renaming should work (verified that I could rename the Intro project myself just now). What problem are you having with this?

The speeds/feeds in Easel currently do not take your bit size into account. That is something we plan to add. I’d say in general if you’re using smaller than a 1/8" bit you might want to dial them down to be more conservative.

Post pictures and/or a project page if you do make the vacuum attachment. I want to make one of those myself.


@JeffTalbot My first 3 attempts to rename a project all failed. I tried renaming “Intro to Easel” to Test Logo. The first 2 attempts yielded no result, the name remained the same. The third just added escape characters to the existing name, renaming “Intro to Easel” to “Intro to Easel” rather than Test Logo as I had defined. Eventually I was able to get it to rename.

I’ve been running into a lot of UI/UX issues with Easel like this. Might not be a bad idea to add “beta” after the name so users know what to expect. It’s not a bad thing, software has to start somewhere, and they are actively making improvements based on feedback and providing an amazing level of support, but acknowledging that it’s not “ready for primetime” may ease some expectations.

As for the speeds and feeds, I assumed Easel took the user-defined end mill size into consideration as it is handling all the presets.

I’ll post pictures/files when I make my first shop vac attachment. It will likely be flat-pack style so it can be laser cut out of acrylic and attach using magnets. I’m basing the design off an attachment for the ShopBot I work with,.

So, I finished my build last night, I knew I would find some bugs and it sure didnt take long to find them either. I too fell victim to the limit switch install miscue, I installed my x axis and y axis extrusions upside down, never even gave it any thought as long as the rails were in the correct orientation I didnt think it mattered. I did find success in flipping the limit switches upside down and adding the post-insertion clips. That made me feel a bit better. Now if I can figure out why my Y Axis is making weird sounds and losing its position I think I might be set finally.

I too agree that the way all the wiring ended up all over the power supplys is messy and unkempt, I am looking for a solution to fix that.

When I first powered my maching on, only the z axis would drive, i found that I had to remove the arduino and the shield from the case and press them together and make a better connection for the machine to work, now i cant screw the arduino back to the bottom because the case sides are in the way.

These are good forums, im glad people are posting to them as we are all learning this machine and its bugs together.


@JamesMurray If your Y axis is making odd sounds it could be a number of things. I’d check that the belts are not too tight, which could cause strain on the stepper motors, or too loose, which could cause slippage. I would also make sure that the rails are free from debris/obstructions, and check that all your wiring connection points are solid. If a wire is vibrating and connecting intermittently it could cause all kinds of headaches.

You can also try removing the Y axis belts and seeing how freely everything slides back and forth. If one side is binding up it can create torsion, which would stress the motors, create chatter, or other not-so-fun things.

I’d also check that the set screws on the stepper motor pulleys are nice and snug. That could also cause a difference in how the two sides move in tandem.

The Arduino not seating properly is a bit concerning. Normally these type of shields slid on and seat quite well. I’d double check that you don’t have any bent pins.

And I totally agree, the forums (and the support from Inventables) are great!


Hi @JamesMurray,

Another item to check for with Y axis problems is to make double sure that the stepper motors are wired to the terminal blocks correctly… one should have a different wiring from the other.

Thanks for all the tips! So I went back and really took a hard look at the setup, I found some of the wheels loose and the belts not tightened correctly. After taking my time with that now the y axis works great. Did my first project on it yesterday with no issues. Very Happy now! One thing I did was attach some small zip ties at the ends of the belts to help keep them locked down.

@JamesMurray Glad you got everything working! I originally had issues with belts slipping when attaching them based on the instructions which rely on friction alone. I resolved this issue with about an inch of heat shrink at each end. This holds the folded belt together and is still flexible. The only down side I’ve found to this method (so far) is that it makes changing the belt length a bit more difficult. Removing the heat shrink to adjust belt length is pretty easy though, and once you have it dialed in you are good.

Congrats on getting your machine up and cutting!

First two carves went great, now, each carve I am experiencing the Y axis will eventually misalign.

I’ve followed all the comments on the threads, but nothing is working at the moment. I checked the belts, checked the wheels and checked wiring.

The carve starts fine, on one project it completed the first ‘level’ of cut, began the second level and then eventually shifted the cut. I have yet to see it actually happen as my latest projects have been over an hour in and tough to watch the entire time. On the video, the guy says belts ‘as tight as guitar strings’. That’s the only thing I’m a little unsure about. I would say I have the ‘taught’, so when I lift on them they are firm and snap back, but maybe not as tight as guitar strings (at least as I know guitar strings to be?). Can someone give me a nudge as to how ‘tight’ this actually is? Maybe I have quite a ways to go in tightening them?

I have a message into Easel Help tonight in addition to this post and will follow up if I hear anything different than the above.

I was victim to installing the MakeSlides upside down as well per the video, but am leaving as is. I like the idea of just switching the limit switch so will do that - - - thx!

I am experiencing a bed leveling issue on the 1000 as well - lower on the left, higher on the right. Any tips would be helpful.

Although I don’t have mine yet, i’ve been reading all the posts and saw this gentleman had the same issue and slowed down the Y axis speed and that cured the issue Inventables forum post

Hope it helps

1 Like

Brian, Thanks for responding. Here are some photos of what is occurring that may help explain the actual type of shift occurring. One fairly large leap, roughly 2-3 cm

Hopefully slowing down the rapid travel wil fix that shifting issue.
For the 2nd pic though, what type of endmill or router bit were you using? That is one ugly looking cut - like you just tied a rabid beaver to the spindle, taped the power cord to his tail and cranked up the electricity to “rotisserie” level. :smiley:


Hahaha. Yes. Couldn’t agree more. I bought some ‘craft’ plywood from Menards to test on and it frayed something horrible when it was milled. I was using a two flute carbide straight bit thinking it would prevent chipping, but not exactly. Would a spiral bit have worked better?
I currently have chosen ‘Birch’ in Easel. Are you saying to choose a harder wood in Easel with different spindle speeds to slow down the inches per minute?