My Z axis is not working correcly

Hello comunity,

So, I have a shapeoko 2 and i use Mesh Cam and Universal G code sender. Yesterday I did some changes on G code sender to improve the speed of production of my pieces. I changed the $110, $111 and $112 (from 300 to 2000, all of them). These changes produced some unexpected changes on my machine behavior… It seems that now my Z axis is somehow inverted… I know how to invert the z axis ($3 and $4) but that’s not helping me… When I start running the code everything is ok. The spindle goes up 5mm like i defined on mesh cam, goes to the first point and starts drilling. The problem starts when it moves to the second point…By that time the spindle is no more 5mm above the stock but 1mm or something like that and from that point on instead of going deeper and deeper layer after layer (depth per pass=5mm) it starts going up, getting further and further form the stock layer after layer… Pleeeaaaase, can someone help me out?

Can you post all your settings via the $$ command?