Inventables Community Forum

Need help tried getting picsender to work for jtech and lost easel

It was, must have bumped it. Thanks Larry on less problem to solve

scratch that the laser does not turn on now with laser or spindle selected in picsender

If you have removed the power from the laser you must hit the reset switch for it to work again.

So to use picsender safely I need to change files somewhere with the spindle laser control peramiters and soft limits for a 1000mm machine. I have no clue how to do either or where this is done still. I see the file posted by Lary but it says 500mm machine so I assume the soft limits will be wrong and is this something that only needs to be done in pic sender or do I need to set soft limits in easel somewhere because of the jtech grbl killing my homing switches? I guess once I get pic sender all working they way it should I will worry about easel connecting after since I would still like to utilize it as well

I did reset it and its on when switched to CW but no control through pwm for some reason

Here are the settings that I use for testing the laser code with my 1.0c

Some of them will be different for your machine,

How do your settings compare to these?

$0=30 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=18 (status report mask:01110011)
$11=0.005 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=1 (soft limits, bool)
$21=0 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$30=255. (rpm max)
$31=0. (rpm min)
$32=1 (laser mode, bool)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=188.947 (z, step/mm)
$110=7650.000 (x max rate, mm/min)
$111=7650.000 (y max rate, mm/min)
$112=2540.000 (z max rate, mm/min)
$120=8000.000 (x accel, mm/sec^2)
$121=8000.000 (y accel, mm/sec^2)
$122=150.000 (z accel, mm/sec^2)
$130=290.000 (x max travel, mm)
$131=290.000 (y max travel, mm)
$132=88.000 (z max travel, mm)

where do I find those settings?

In the Demo, the GRBL menu is disabled, so you need to make the grbl setting changes in

Select the $$ button.

1 Like

$0=10 (step pulse, usec)

$1=255 (step idle delay, msec)

$2=0 (step port invert mask:00000000)

$3=3 (dir port invert mask:00000011)

$4=0 (step enable invert, bool)

$5=0 (limit pins invert, bool)

$6=0 (probe pin invert, bool)

$10=3 (status report mask:00000011)

$11=0.020 (junction deviation, mm)

$12=0.002 (arc tolerance, mm)

$13=1 (report inches, bool)

$20=0 (soft limits, bool)

$21=0 (hard limits, bool)

$22=0 (homing cycle, bool)

$23=0 (homing dir invert mask:00000000)

$24=0.000 (homing feed, mm/min)

$25=0.000 (homing seek, mm/min)

$26=250 (homing debounce, msec)

$27=1.000 (homing pull-off, mm)

$30=255. (rpm max)

$31=0. (rpm min)

$32=1 (laser mode, bool)

$100=40.000 (x, step/mm)

$101=40.000 (y, step/mm)

$102=188.947 (z, step/mm)

$110=8000.000 (x max rate, mm/min)

$111=8000.000 (y max rate, mm/min)

$112=500.000 (z max rate, mm/min)

$120=500.000 (x accel, mm/sec^2)

$121=500.000 (y accel, mm/sec^2)

$122=50.000 (z accel, mm/sec^2)

$130=740.000 (x max travel, mm)

$131=790.000 (y max travel, mm)

$132=100.000 (z max travel, mm)

If I have it set for spindle M03 and M05 button on the bottom right will turn the laser on and off but when I run the file it does not

Getting there very slowly lol I clearly had no clue what I was getting into with this

Is the Send M03 selected?

yes

I have not changed any settings in the grbl anywhere yet though is that the issue?

Spindle mode controls both my router on off and laser on off with the m03 m05 button I have a solid state relay trigger with a laser/spindle switch setup. The test file does not send the on command with either selected

Not that I can see. I assume your testing with the same gcode file you attached above. It has a M03 (On) then a M05 (Off) afterwards. The PWM does not go high until about 45% of the file run. That is where the next M03 is to turn on the PWM.

Remove the M05 at the beginning of the file in a text editor and try it again.

1 Like

That did it thanks… another stupid question… how do I make it not leave dots at every direction change? I think I have this working enough to purchase. If I get picengraver will it be all set up for variable power now too?

There is a problem in the post processor file that generated the g-code posted above. It should have generated an M3 for the first G1 command and it didn’t.

That was the recent jtech no Z movement pp file for vcarve

I’ll take a look at it.