Need help! ZAxis will move up but nothing in X Y

I had used my XCarve 1000mm with XController just a few days ago, as I have for hundreds of hours of use before, and just now when I turned everything on, started UGS, hit to home the machine - Z went up, but then nothing… When it would usually start rolling forward on X and Y to go home, there is no movement, no sound, just nothing.
I can still run $$ and get my settings, it says its communicating with it but just nothing happens in X and Y!
I always have everything running thru a APC Battery backup and surge protector so I don’t think it zapped.
I have shut everything down, waited a few minutes, etc - all the same result. Also tried running in Easel to home it and I get the same thing - it raises Z, but then nothing happens with X and Y.
Is something dead on the board?
Any ideas of other tests I could do to narrow down the issue?
Also thought I would add in that I have checked all V-Wheels, Belts, Belt tension, etc… Nothing is binding, in the way of movement, etc…
Thanks in advance!!!

Here is my current settings as well:
$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=4 (dir port invert mask:00000100)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=115 (status report mask:01110011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$30=255. (rpm max)
$31=0. (rpm min)
$32=0 (laser mode, bool)
$100=39.926 (x, step/mm)
$101=39.899 (y, step/mm)
$102=188.976 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=0.020 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=790.000 (x max travel, mm)
$131=790.000 (y max travel, mm)
$132=100.000 (z max travel, mm)

Not related to your current problem, but $111 should be 8000.000 ($111=8000.00)

X and Y not moving indicates that “home” was not found on the Z axis.

Check your wiring on the Z axis homing switch. If you have a voltmeter verify that the wire to the Z axis switch is almost 5 volts for normally open switches, or almost 0 volts for normally closed switches when the Z axis is not contacting the switch.

As usual Larry, you sir are a genius!!
Changing that setting worked!! I have no clue how that $111 got set to that value though in the first place.

Also, thanks for the tip on how to check the voltage on the homing switches - I checked all of them and they are ok.

1 Like

Yep, that’s possible. :frowning:
From the last time of switching from laser back to spindle.


If you are using my 1.0c laser grbl or the official 1.1f version of grbl PicSender($25 license) will take care of switching between laser and spindle grbl changes, one button click.