Need UGS Help Please


I was hoping that I could impose upon you folks for help.

My machine works flawlessly when using easel. But I need to send various files to the machine from V-carve,

First I tried by downloading a very simple file using Easel. It didn’t look quite right in the easel preview. ( A six in circle, 1/8" deep - looked way oversized and cropped.) When I started it, the entire gantry came flying forward. Luckily I hit the stop button before it smashed into the front rail supports.

Then I decided I would give UGS a shot. Downloaded UGS, Java, etc etc.

I can get the machine to jog each direction. It seems to download the file fine, as I can see the lines of code flying by.

When it is actually time to get going, the Z starts to “spazz out.” Sort of goes up and down a fraction of an inch (or back and forth when looking at the drive rod) just a bit continuously, then the computer starts to download the file, and nothing on the X-carve progresses. Just keeps spinning it’s wheel so to speak.

Any thoughts or help would be greatly appreciated.

BTW, using Windows 10 on a pc, X-controller, inches to inches and mm to mm are right.

Thanks very much,


Which post processor are you using?


When I tried it in Easel, I used the XC inches version.

When I tried it in UGS, I think it ended in .tap (the inches version.)

I just noticed that with the Easel/Vectric combo it wanted me to download a .pp file and place it into a folder titled postp. I can find the folders for the Vectic and Artcam programs with that name, but not a folder for Easel.

(Sorry to be dense, but I am a MAC guy. I bought the PC specifically for this.)

Thanks again.


One more note. The second file I tried to send, did have a TAP extension. That was actually an image file from PhotoVCarve.

Thanks again.

Hi Guy, forgive me if this seems an obvious question but have you calibrated the x-carve controller using UGS yet?

open up your Vectric program and under the file menu you will see a menu item for “Open Application Folder” click that and the directory for your Vectric program will open and you should see the My_PostP directory which is where you want to put your post processors. Once you put them it that directory that will be the only post processors you see from the post processor drop down list when you are saving a toolpath

Hi Jon-

No. No idea how to do it, never saw anything that actually mentioned it.

Can you point me to a link or tell me how.

With what I have now done, it looks like I can only do it through easel.

Hi Allen-

Thanks, I have it running now.

Thank you both…


Hi Robert-

Are there any size limitations or any reason as to why I should use anything other than easel?




Then I think I will stick with Easel. It hasn’t let me down yet.

Thanks to following what Allen Massey suggested, I have a mold for a lithophane cutting right now, and so far it looks perfect.

Thanks again!