Never can finish a job - help!

Ok I have looked around but nothing seems to solve my problem. My xcarve ALWAYS stops at different times through the job. It disconnects for about a second and then the carve button is green again. I have checked my wiring on my x-controller 6 ways to Sunday and see nothing amiss. Help please I am becoming increasingly discouraged that I will never be able to carve anything.

It could be your USB.
It could be a bad cable.
It could be issues with your USB port not putting out enough current, people with similar problems found that using a powered USB hub fixed the issue.

2 Likes

Thank you for the quick reply! You are right. If I remember correctly the USB port on my surfacebook is a bit underpowered. I have swapped the cables and ports with no luck.

1 Like

Okay so give me a complete run down of your setup

All computer specs

version of the x-carve and controller are you using the new x-controller or the old one?

256GB Surface Book with Intel Core i7

And I have the 1000mmx1000mm xcarve that was purchased last November so it is older. My x-controller was purchased in February right after it came out. I’ve been deployed so I am finally having a chance to get everything running.

That may be it. A powered USB would fix that issue. If you have a different PC you could try it with that could help test to see before you invest in a powered USB hub.

have you changed all the power settings on that surface to make sure that it never goes to sleep or tries to switch off

what are you using for a internet connection? I assume its just over wifi? and what browser are you using on the surface?

1 Like

I have it to never sleep and have been sitting to watch it to see if anything happens just before it stops. I use wifi and I have tried Firefox and chrome but usually stick to Firefox as it runs better on the surface book.

I am thinking that the USB port is inadequate. Unfortunately it is my only computer at the moment.

I know this article pertains to older versions of Windows, but it is still valid for this situation:

1 Like

yeah I not sure I figured that any usb 2.0 or 3.0 port would work

let me know your findings

have you tried to call inventables directly and talk to someone there they might be able to help you quicker

There are a number of potential causes of this sort of disconnection — list of them and some potential solutions here: http://www.shapeoko.com/wiki/index.php/Electronics#Recommendations

You should try the ones which are convenient for you / which you are comfortable trying, then if that doesn’t help, contact Inventables support to work out what can be done for your situation.

1 Like

The port is either shutting down due to over current or the system is trying to shut it down for sleep.
One of the reasons laptops are not recomended.
You can overcome the current issue with a powered hub.
The sleep thing you can set up the laptop to never sleep.

I had this same issue running off a surface pro 1 and the powered USB hub solved my problem, I’m betting that is your issue.

2 Likes

That’s I was gonna suggest, Externally powered USB hub is the solution for every Portable or Laptop devices.
Also I want to add that, USB 3.0 or 3.1 works as well. Good point Bob.

I have a laptop I use all the time and it can run for hours.
I turn off the sleep and screen savers.
It works ok for me.

Powered USB hub fixed my problem. I am also really careful to not flip any switches that are on the same circuit as my X-Carve.

I had a box fan plugged into the same outlet as my X-Carve. I turned the fan on and my X-Carve stopped. LOL!

sweet yeah make sure your x-carve is on a dedicated circuit when its running

check out this thread above we were having a pretty good discussion on the topic

Thanks everybody for the help. I got a powered USB hub and rechecked my shielding ground wire on the stepper motors. I thought that fixed the problem. My job ran for like an hour before it stopped! Its an improvement though.

If you haven’t looked at this, It has helped a few people:

Check your GRBL settings. If you are running in limit switch mode, you may be getting false signals on your switch wires. The quick fix is to put the switches into homing mode.
If the spindle shuts of when it stops then that is probably it.

Later on if you want to set up limit switches there are a few threads addressing that.