New noise in both Y motors. SOLVED

Tonight, after accidentally running at excessive feed rate, I quickly disconnecting the USB and then I got a new noise coming from both Y motors , after a reboot. It’s much louder than normal. I saw other posts saying this is normal for the motors to make noises, but I am concerned that I messed up something here, way louder than ever. Video attached :

Link to video doesn’t work.

EDIT Now it’s marked as private

You mentioned that you disconnected the USB cable, but did you leave the 24 volt power supply on?

Have you tried dropping the voltage to the drivers with a screwdriver?

I pulled the USB, shut down the PS. Turned everything back on, and then the new noise.

I turned the voltage down, the sound went away, but it wasn’t nearly strong enough to hold itself in place. So I slowly turned the voltage up, sound came back, still not strong enough. Continued to turn up voltage, it never got strong enough before it cut power to the steppers. So does this mean I fried the card or my steppers, or something else?

It would have been better to turn off the 24 volt power supply first and then unplug the USB. The gShield limits current to the stepper motors to keep from damaging them with excess current. When you unplugged the USB the Arduino and gShield logic lost power, but the 24 volts to the stepper motor drivers was still on. In this scenario you could have damaged the power supply (not likely), the gShield, and/or the stepper motors.

If you disconnect the Y axis from the gShield do the other motors work correctly?

X and Z work fine. Thanks for the help. Next time I will kill them 28v first.

Ok, disconnect the wires for the X motor at the gSheld. Connect the Y axis wires to the X location on the gShield. Test to see if the Y motors work ok when connected to the X position.

1 Like

Good idea. Ok that will tell me if I have a bad motor ,right? If I find the new motor doesn’t work, then it is likely that the gshield is bad??? Thanks again… I’ll try this asap

OK, I switched Y to X and now my Y motors are strong as always! Ok does that narrow it down to just the gshield as the issue, or could it be the other card? Thanks for the help! Awesome advice Larry

Yes. It appears that the Y stepper motor driver is damaged on the gShield.

1 Like

Ordered it already! Thanks for your help!

1 Like