New problems with laser

alright so I’m using vcarve to do an outline and some letter fill in. when it gets done with a part of the image and moves across the board to the next it screams across the board at max feed rate and abruptly stops and shakes the laser out of focus. I’m thinking one of 2 things here that I’m going to have to make my laser more stable or can I just change the maximum federate somewhere in vcarve desktop

Take a look at the g-code file. My guess is it is doing a G0 rapid move to go to the next cut area?

I am not sure where you would change that. I am thinking it would be in the post processor.
If you go to VCarve’s help section there is a “Post Processor Editing Guide”.

It looks like this is what you add to edit the rapid move code.

RAPID_MOVE
±--------------------------------------------------

  • Commands output for rapid moves
    ±--------------------------------------------------
    begin RAPID_MOVE
    “Commands”
    Commands that are output when rapid moves are required.

The post processor I use has this:

±--------------------------------------------------

  • Commands output for rapid moves
    ±--------------------------------------------------

begin RAPID_MOVE

“G0 [X] [Y] [Z]”

Probably the most simple approach would be to make a separate Laser post processor and change the G0 to a G1 instead?
As I think the G0 speed is actual set in the GRBL setting somewhere and would be annoying to change back and forth between laser and CNC jobs.

And, as always, I recommend modifying the header:
Removing the “T1M6”
Adding a units used “G20” inch or "G21"mm
Adding an absolute mode “G90”

I don’t really know how to edit the pp however Iclled j at jtech and he told me how to edit the gcode and Ive don’t that with the g0 and g1 with success

It is pretty easy to do. The Post Process is just a text file located in the application folders. It has the *.pp extension but can be opened and edited with notepad or any other text editor.

To find it open VCarve, got to “File”, “Open Application Data Folder”
This will open the application folder
Then open the My_PostP folder
In there you will find the post processor files.
You can edit them and then “Save As”

Tip: You can change the name of the post processor as it is shown in the pull down list by editing the line:

POST_NAME = “X_Carve (inch) (*.gcode)”

ahhh gotcha
now I have another problem with it

At the very beginning when I turned it on to start an image it turned the laser on and created a line to where it starts

Sounds like you have a laser on command at the top of your gcode file before it moves to the start position. Check your gcode for where the M3 or M03 commands are. In fact best to learn basic gcode if you are going to laser from XCarve, you’ll need it :slight_smile: