New to UGS and Aspire, need assistance

Okay, So I was able to create a sign in Aspire, using 4 tool paths, and also downloaded the UGS 2.0 found in some previous posts. Now I am at a loss. How do I get the toolpaths into the UGS and into the x-carve? I was doing fairly well up until now. All the toolpaths are saved as Gcode on my PC, but that’s about all I have, thanks in advance

Also, when I try to open the port, it says it’s busy? In my devices, it says the Arduino is on COM4, but when I open Arduino, it says it’s on COM1. I can open COM1 in the UGS, however, if I try to move the machine controls, it says “Grbl has not finished booting”. no idea what some of this means.

Usually gives that error message if com port speed doesn’t match. It must be something like 11520.

1 Like

The baud rate needs to be set to 115200 in UGS to match the Arduino.


I think I had it set to that. I am at work for the rest of the day, and I will give it another go tonight when I am home. Thanks!

I missed one zero again, darn. Thanks Bill.

1 Like


I wish I could find another zero or two in the right places! :laughing:


Okay, so I was able to connect it and get it going. Did a test run with the router off and no work piece, and it looked like it was going good. Then I went out and got a piece of wood to test on and now the thing is all over the place. I zeroed it out on the bottom left corner and hit send, the carriage goes to different places now… what happened? help a noob out! Its odd that they sell the Aspire software with an x-carve, but it’s difficult to get them to work together.

Damn Scotch, stay calm, stop spinning my vision.

1 Like

I was able to carve 1 tool path from Aspire, however, I figured out that I had the zero the board in the middle of the material, not the corner as I have set in Aspire. Not sure why it’s doing this.

When you start UGS, hit $x first if it is red than $H button to home the machine. This is your Machine Zero. After that, Jog it to work materials lower left corner, align it well and click Reset Y and Reset X buttons. Again, Jog it to any flat surface of the Work material and lower the bit down small steps until barely catches the piece of paper and click Reset Z button. This is your Work Zero. Now you can browse and load your Gcode and click send button. It will return to X and Y zero point (Lower Left Corner of the work Material) first and start carving anything you see on Aspire screen.
You must understand the difference between Machine Zero and Work Zero. Machine Zero to tell the machine coordinates this is Zero point. Work Zero to tell the machine this is my work piece’s position. If you clamp your material to absolute lower left corner of the waste board, all you have to do is Z zero resetting with the piece of paper.
I hope this helps.


This helps A LOT @AlanDavis I will give it a go tomorrow night when I get home from work. Thank you!!

1 Like

If you’re going to use the $H command to home the machine, make sure you have installed limit switches and that they’ve been set up (in Easel is easiest) and are working correctly.

Warning. If the limit switches are not fitted, or not working, the homing command will drive the machine into the stops at the end of each axis

When setting up UGS after a reboot, on my machine, I need to:

  • hit the “refresh” button (the two circular arrows)
  • i then find the correct port in the drop down list (on my Mac, this can change each time I boot it)
  • having selected the port, I then click on “Open”. If successful, my machine makes a noise and then UGS shows a message in red. At this point, send the command $X (you can click the $X button on the machine control tab, or type the command in yourself)

If this has been successful, the arrow keys on your keyboard (and Pageup and Pagedown) should index the machine around for you careful, if the machine is set for “inches”, pressing an arrow key may drive the machine into one of the axis ends - I’ve broken a couple of Z limit switches this way.

1 Like

@DavidWestley I have the limit switches, however the machine still hits them when I’m not i easel. I may have to go back and reset them in easel.