New to Xcarve - z axis cutting air

Hi there,

I just finished putting together the ner 2021Nov XCarve with the Mikita router.

I have started homing and testing it with the basic structure (robot and name) but unfortunately, the first several passes, the z axis was cutting air. I also tried “cutting” it through with the same depth of my material but it only cut portion of the depth.

I have uploaded the gcode (hope I did it correctly). I also read that I have to change the $132 to 152.5mm (not sure if this is a good change either).

Any help is appreciated. THank yoU! (304.8 KB)

1 Like

Hi Rob, you’re not alone in this issue,… its quite common problem with the new Z axis. . . there is a step where the Z assembly is bolted onto the gantry, and there are 4 screws, these can be loosened an then the Z assembly needs to be dropped to a point that your shortest bit can reach the wasteboard. placing it as high as shown in the assembly allows users to use long bits and fit thick stock, but most users will not be using 4" stock and super long bits, so they will usually need to lower the assembly a bit. . .

the bottom of the z assembly needs to be lowered…in this photo it’s shown too high, you’d loosen the 4 screws and lower the whole assembly as needed…

Changing the $132 does effect the Limit Settings (Kinda, make sure to read the BUT part and the note at the end), these can signal to the user when the Z movement has or will exceed the maximum setting (like yours is trying to do by over plunging). . .
BUT these limits are turned off as defaults… IF you want to prevent crashes and the steppers driving when there is no more distance to possibly move you’d need to set $20 to 1
Here’s some more information about turning on soft limits or hard limits. . .

IF you don’t turn on $20 then the $130,131,132 settings do nothing at all.

Hey I think that did the trick!

Thanks a lot! Now i gotta see if I can cut through the whole piece :slight_smile:

1 Like