New/Used Xcarve connection issue

Hello all,
New to this forum, I just recently purchased as used/new Xcarve. I am having connection issues, as I dont’ use Easel and don’t have internet in my shop. Have tried to connect to UGS but UGS doesnt recognize the USB, even though my computer does. I use Carveco for design and gcode output, so I Just need a reliable motion control software. Any suggestions would be appreciated.

1 Like

I use OpenBuilds Control and it works great, that said I also have UGS and it also connects without issue. The thing is that since UGS isn’t actually an installed application it might not have necessary permissions to access the port, so you might try right click and “run as administrator”
Another common issue is that some laptops use USB cloning and only one port is the master port, so try different plugs on the laptop if applicable… also you can go into device manager then locate the tree called “Ports” (while the usb is plugged in, you can unplug and re-plug to help find this section as it will disappear and reappear when the usb is inserted) and the you can go into properties to verify baud rate is set to 115,200 and then go to “advanced” and ensure the COM number is NOT set to 1 thru 3 (you can manually reassign to any unused number 4 or higher) THIS usually fixes the issue, However sometimes AntiVirus and/or Firewall settings could also stop UGS from gaining access to the USB port.

Or give OpenBuilds a shot… either way, If you do get it working, please let us know what route worked for you.

double check, see if you have post Prosser and drivers

Easel - Downloads (

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.