New user. Beyond frustrated. Cuts are way off (Y-axis issues?)

I’m just beyond frustrated at this point. I bought this machine with high expectations, and my wife has big cutting plans (she wants to cut name signs out of MDF), but none of those plans are going to come to fruition if I can’t fix this.

I adjusted the right side of the X axis, because I noticed it was a tad taller than the left. It’s still not getting all the way through on the right side. Even after that, it’s still not cutting through once it moves to the right.

The right side Y axis also keeps sticking, or dragging behind the left, or something. To the point where I’m a full 1/2 inch off on parts of the cut (see circle attempt below). I don’t know what I’m doing wrong at this point. Any help is appreciated. I know I’m new to this, but I’m trying to learn what I can as fast as I can. I see others with amazing creations on here, but I can’t cut a simple circle at this point.

Here’s a video of the right side dragging.

First of all, did you calibrate the x and y steps per mm. Did you adjust the vwheels so they just barely turn with finger pressure? What’s your depth of cut and feed rate? Did you adjust the belt tension? If that’s maple, then you need to go slower on the feed as it is dense. FWIW, it’s going to take some tweaking to get it to perform at its peak.

I would also double check your Y Axis wiring, dragging sometimes occurs if (A) One of the motors isn’t plugged in or (B) One of the motors polarity is wired incorrectly (they should run opposite of each other to move in the same direction) Go back to square 1, tension the wheels (too loose is bad, too tight is worse) Tension the belts (where you can pluck it like a guitar string and it has some play) and double check your wiring. Last, calibrate! I also like to use an “L” to make sure my router is installed straight and true. Your base needs to be level too, I used a 1/2 sheet of MDO with adjustable leveling feet as a base to my X Carve to level it out. You got this!

1 Like

I did calibrate, but I’ll go back and try it again. vwheels might be a bit tight, so I’ll check that. Belt tension feels even on both sides. Tight, but not super tight.

It’s birch ply.
Depth is 0.05 in
Feed is 40 in/min
plunge is 12 in/min

First of all, verify that Y1 and Y2 stepper motor work as normal/same relative direction.

Regarding cut depth variations, the spoil board is most likely not even relative to Z. Adjust the frame as close as possible, then skim cut it to make it truly uniform in Z-height. Add a 2nd layer of spoil board if you want to preserve the original.


Mine works exceptionally well, fact is just replaced the router. Maybe something wasn’t hooked up correctly

Thanks everyone for the replies. Haven’t really had a chance to work on this lately, but I’m finally back to it.

I checked and made tony adjustments to the v wheels, I checked to make sure I’m level, etc. everything appeared fine there. I checked wiring and checked it again. Nothing fixed it.

Then, I decided to unplug the Y1 and try jogging it a mm. Nothing. Plugged it back in, it jogged. Pretty clear now my Y2 stepper either isn’t getting power or it’s a bum motor. One of the two. Going to see if I can figure out a way to run a different set of wires to it tonight to see if that makes a difference. Maybe I can then work on eliminating if it’s the board, the wires, or the motor. I’ll keep you posted!

1 Like

With power off, swap the Y1 and Y2 at the controller. Power back on. Does it move?
Steppers rarely have issues. Stepper drivers, on the other hand can have issues and you can destroy them.

Yikes. I’ll try that. Hope I didn’t break anything.

Great suggestion. Tried that, and sure enough, Y2 moved but Y1 didn’t. Left a message with customer service, but I’m guessing something is wrong with the controller.

Is it the same motor having issues or the same “port” on the board?
Motor = Wiring issue
Port = Driver (probably need a new controller)

Once I switch Y1 and Y2 on the controller, Y2 works and Y1 doesn’t, whereas before it was the opposite. Pretty sure that narrows it down to a controller issue.

It’s brand new. So hopefully I can just get a replacement and go on my way.



Guys, it works. Inventables sent me a new x-controller. Tested cuts today, and it’s working beautifully. Thanks everyone so much for all the help!

1 Like