New user need help

I just got my 1000mm X-Carve setup and this is all new to me, I need help with it all but I’ll start with my first problem. When I started up and ran through the calibration the machine will not home. All of my homing switches are working except the Y axis. I contacted Inventables, they sent me a new switch and cable. I installed both and still nothing. Besides changing everything all out like I already have, I don’t know what else I should do.


How do you know this? Can you provide a little more information? What isn’t working? What have you tried?

I tried to home and all it did was make noise. I called Inventables and they had me open Easel, open machine, advanced tab, then open machine inspector. When you manually hit the homing switch there is a green circle to show that switch is functioning, all but the Y register.

can you make a video and post it. The homing switches have to contact something to know when to stop do you have the stops located were they can actually meet the toggle on the switch? I will post a pic in an hour or two. Steve

Hello! I had the same issue with my set up about a month ago. It would just go up and then make an awful noise. I spoke to Julie at inventables and we went through lots of troubleshooting. Finally we discovered the wires were connected wrong. We had installed them correctly but the Y axis was switch with the X axis as they were mislabeled. It was such a simple fix but took a long time to figure out!!!

1 Like

A couple weeks ago a lady on a Facebook group was having a similar issue like Charlie was having, I face timed her and we went over all of her connections and she had the X and Z wires on the wrong stepper motors. She did a video and posted it to Facebook and when she would hit home it would make a very bad noise. So she is up and running now. If you don’t get it working and want to go over your connections let me know and I can face time you.
Good Luck

Thanks for the reply, just wanted to double check with you, when you went into the advanced settings where it has the green circles showing that the switches are functioning, did the X axis register as working or were all your homing switches working? Mine does exactly what you were saying, when I try to home it the machine makes an loud noise.

It was in the initial test and I could not make it to the next homing cycle as it would go up and make awful noise–we had to keep hitting the red button! Yes though—all of the green buttons were lit up as working. I was ready to pull my hair out and then such a simple fix—the wires are the same size and it was just a simple error that they were labeled incorrectly. Once we swapped–it has been great. I am completely new to this as well and was feeling a bit overwhelmed but I learn more everyday and have made some beautiful projects. I hope this does the trick for you.

You are saying it makes a loud noise without any movement? Usually the “loud noise when homing” issue is an axis reaching it’s limit and being unable to move.
Try this:
Power on the machine. (Do the motors lock?)
In the machine inspector, in the console, type $X and click enter. (This will unlock the machine)
Try to jog your Z axis down and up. What happens?
Same with X and Y.

When your carriage makes it to the front left corner are your switches making contact like these images show when doing your homing sequence