Inventables Community Forum

New User with a problem I can’t solve

Hi everyone. I’m new to the CNC World having just had a 3018 pro for Xmas. I’m having real issues with Easel Pro. I’m only on the month trial at the moment before I purchase it but so far it’s had me pulling my hair out.

I’ve read every single post on the forum from users experiencing the same problem as me and tried all the fixes but still no joy so thought I’d see if anyone has had this problem more recently than the last post.

I have not been able to complete a single project on Easel Pro yet, which is a shame as it’s such a user friendly program. My machine gets to different stages of the job and then it just pauses where it is with the spindle spinning. I have to manually stop it and it will return to the start position and brings up the Easel ‘How was your job’ screen. I must have tried over 30 tests on it and none of them have completed.

So far I have done the following:

Tried every USB port (5 on my laptop)
Made sure that the USB’s were set to not turn off to save power
Tried running it through a USB 3 switch
Tried 3 different cables (one gold plated USB3)
Re-routed all the CNC cables to make sure I wasn’t getting any interference
Moved the power packs for the machine and laptop away from the router
Calibrated the CNC
Measured and corrected the exact grbl settings for the x,y & z axis
Measured all the bits and made sure the correct one is set (1/4” & 1/8”)
Tried slowing down the feed rates, reducing the depth of cut etc

I’m out of ideas! I really like the user interface of Easel but I’m not sure what else to do. If I export from easel, and import that file in to carbon create, I can then export the the G Code from there and load that in to my grbl controller and it works ok. I’m certain it’s a software issue, as I have used the machine with light burn for hours on end messing with the laser and never had a problem with it, so if it was a usb drop out or interference issue with the stepper motors I’d expect it to have the same problem but it doesn’t. The only thing I can think it could be (but the forums say different) is unstable internet as the machine is in my garage and I don’t need it for Lightburn. But from what I’ve read, once it’s been designed and sent to the machine for carving it doesn’t need an internet connection, is this correct?

Bit of a long post for a first one but I’m scratching my head now so thought I’d ask for some guidance or thoughts.

Thanks

I am having the exact same issue. It isn’t consistent, but it just seems to lose connection mid carve. I did some digging and it seems like the computer is allowing the USB to go to sleep. I used this reference to disable that feature on my laptop - Disable USB sleep settings (to correct backup device issues) – NovaStor Support.
No guarantees - I haven’t tried it yet, but I am thinking this may be the fix.

Let me know if it works for you. I’ll do the same.
Kevin

Sounds like it could be electrical interference are you using limit switches or using soft limits
Led or fluorescent lighting
Shop vac?
All these items can cause these intermittent problems

If you are running dust collection have you grounded it? typically dryer in winter so higher static.

Hi everyone thanks for the replies. I’m not using any limit switches or dust collection. It’s only one of the small 3018 machines.

I have already made all the settings In the Device Manager/USB to make sure that they were set to not go to sleep to save power.

If it was some kind of interference issue effecting the stepper motors, or something with the USB dropping signal for a split second, why does the exact same setup work faultlessly with the Lightburn software or with another grbl controller? I’d have expected it to do the same thing but it only happens with Easel. Very confusing! I’m absolutely gutted because Easel is a great program, but I can’t complete anything with it.

My plan for today to add another layer of fault finding to my problem, is to download the trial of VCarve and then design on there before sending it to the CNC through Picsend. I have also downloaded Carbide Create and Carbide Motion, however whilst I can design in create, motion won’t see my machine. I think it’s only compatible with the Carbide CNC machines. Create doesn’t appear to be anywhere near as good easel anyway. But the combination of these programs has proved useful for exporting the GCode

I have a small LInkSprite that I have used to cut some small Easel jobs. It is small enough that I felt my children could safely use it. It came with GRBL which is able to control it.

I create the project on Easel and then export the G-code. I then have GRBL send the G-code to the mill.

I also had problems with the sleep settings on the computer. I have a shop computer that does nothing but run the software for the machines it controls. Since it is not a laptop and runs off of a power cord, I shut off all power saving features. It will not blank the screen, lock the keyboard, go to sleep or anything else. It simply runs until I turn it off.

Try some of the things I mentioned above and see if this helps.

I have used my two X-Carves for thousands of hours in the last 5 years cutting mostly foam projects. I had to wrap the dust collection hoses with bare copper wire running to ground as well as moving the vacuum dust collector away from the controller to control the static. In the winter here in Colorado it is dry. I used a humidifier to keep the static down. My machines were stopping mid job a lot until I realized the problem: a high amount of static caused by very low humidity interfering with the controller. My controllers are Pi 3.0 driven.

1 Like

Well It’s beat me. I’ve been on it for 5 hours today with no joy! I downloaded the trial of VCarve but you can’t export GCode in the trial version of it. So the only GCode I can export is from Easel itself. It doesn’t work in any of the GRBL controllers I’ve tried. I’ve used the Candle software that comes with the machine, I’ve downloaded one called GRBL controller and also UGS. In all 3 of them it starts off ok but gets to certain points then throws up error messages and does what it does in Easel, stops carving and keeps spinning where it is. Now I really want to test a different program to create a GCode from to confirm that it’s not an issue with the GCode write from Easel. The thing I’m struggling to understand is this, if like all the posts say on here, it’s interference of some nature, either electrical, or USB which effects the stepper motors momentarily, then why can the exact same setup, in the same position, control the machine with the laser fitted and the router removed?? The signals are still sent the same way, via an X,Y,Z co-ordinate to the motors to make them move, but instead of turning the router it fires a laser. I’m ready to throw the thing in the bin!! I have tried every suggestion, I’m not running any vacuums, USB’s set to not power off, as is the battery, I am on a laptop but it’s plugged in and not running on battery power. All the power leads are well away from the machine. I give in!

Try running a carve in air, with the spindle OFF.
Does it complete?

I’ve not tried that actually. I’ll give it a go in a minute and let you know.

Well I tried 4 small projects and they’ve all worked fine. I’ve ran 3 as GCodes through UGS and one through easel. One with the spindle spinning and the other three with it disconnected. So the problem was only appearing when it was carving. I thought it could be a possible vibration issue making one of the connectors loose momentarily and leading to it losing its position. I’ve now made sure that the connectors to the top of the spindle motor are secure and in case I was asking to much of the motor I’ve changed all the settings in easel to manual. I’ve set the feed rate to 400 and the plunge rate to 0.8mm rather than the standard automatic ones. I’ve managed to do small text tests successfully with these settings and am now just creating a rectangular cut out at 8mm depth. Hopefully this was the problem and I was just asking a little too much of the spindle motor, or there was a loose connection. I’ll post the result of the final test once it completes. Then all I need to do is slowly increase the cut depths and feed rates until I find the machines limit. Great advice though thanks very much. I’m not as stressed out now :+1:t2:

Success!!! Thanks for the advice. I have one more question, what’s the benefit (if any) of just using easel to design in and exporting the GCode to a separate GRBL controller to perform the carve Vs doing it all in easel?

I have two CNCs. I have a techno Isel DaVinci III and a LinkSprite. Both are not capable of direct connection to Easel. However, Easel is a very good G-Code creator allowing easy creation of designs online.

I have Vectric V-Carve too which is very capable. I use it for carving 3D designs. But V-Carve has a learning curve that takes some effort to power through. Years ago, my daughter was in 2nd grade and used Easel to create valentines which I carved out of wood. Putting easy design power in the hands of people is what Easel is all about.

Finally, the Inventables forum allows the sharing of designs. i have shared some of my designs through the website which have been downloaded and carved by others. There are thousands of designs out there. These give the X-Carve buyer many designs to carve and sell.

More control. Better understanding of what the machine is doing. More options. More feedback. Simpler workflow. Streamlined setup…
I don’t really use Easel. It’s great as a super simple CAD/CAM package, but it leaves some to be desired in the controller department.
Try CNCjs.

Also, your little spindle motor is the electrical noise generator, not the steppers.

1 Like

Thanks for the help everyone. Much appreciated. I’ll certainly take a look at the CNCjs program as well. I’ve just watched a beginners tutorial video on it and it looks really good.

Try a new plug/cord for the usb. The ones from easel break easy.

I also got a 3018 pro for Christmas and been poring through YouTube videos to help me through building it and getting going. Two things that appear to be an issue mentioned a couple of times are electronic noise and static interfering with the electronic. Some people mentioned putting noise dampeners into their connections but I an not electronically adept enough to explain how. The person I saw do it soldered into the wiring what looked to me like resistors. For a static issue here is a simple and cheap thing to try. Wipe down your CNC bed and spindle with a Bounce sheet then place one or more sheets between the bed and your work-piece before clamping it down.

As you can see by the post I was having a nightmare and going down lots of rabbit holes switching cables, USB ports, thinking about interference etc. It was only when one of the replies said to try a run with the spindle disconnected that it worked. That clearly meant the problem was related to the actual carve. I suspected I was probably asking too much of the small motor and spindle when left at the default easel settings. I now run it manual with a feed rate of 800mm/min, plunge rate of 400mm and depth per cut of 0.8mm. It takes a bit longer but I’m only doing small things anyway whilst I learn how it all works. So far with these settings I’ve never experienced the problem again. I was obviously over working the small motor. I did a two stage carve the other day on some Oak which measured about 260mm by 150mm and had quite a large 8mm deep rectangular pocket cleared out and it ran through fine in about 2hrs 30. So if you’re having issues I’d start with the settings first and don’t get wrapped up with interference straight off like I did. This post proved really useful for me to solve the issues. It’s an amazing forum full, of lots of useful advice. I’m already thinking of upgrading! I’ve got the bug much to wife’s displeasure as I now spend ages in the garage :grin:

set your laptop so it does not go to sleep, monitor and hard drive does not go to sleep screen saver is ok will still run. fixed mine with same issue on 2 different laptops.

I have had so many issues with Easel that I have now stopped using it. I am not sure if its a problem due to it being an online program only and problems occur because of the Internet connection. I now do the design in Easel, export the gcode and do the engraving by importing into Candle. This is a free program which you install on your laptop and it runs without any Internet connection. This solved my problems. I cant understand why Easel has to be a Web based program instead of a downloadable program installed on a laptop. I am sure this would solve a lot if problems. I would then consider buying the Pro version but certainly not as it is now.