New x-carve and easel don't see her!

Hello !
My new X-carve 1000 is now assembled !

i have installed easel local on to laptop

one on xp pro sp2 with an old version of firefox
one with win 7 starter and last version of chrome and firefox (a netbook)

no firewall, no antivirus…

and each computer do the same thing !
when i try to configure my x-carve, easel don’t see it and wait au usb plug.

but easel service still running and arduino works (i see it on com6 if i start arduino software)

i never use arduino software or another browser with easel allready open while using firefox to configure my x-carve.

someone can help me ? i need to reinstall grbl ? if yes, where to find files ? on github i see only the wiki

@Leroux did you run the blink program on the Arduino? If so you will have erased the hex file and you’ll need to flash it back on.

Do you hear the connection sound when you plug in the USB?

i know arduino, i code on it, but no i haven’t load blink exemple. just launch it to see if it see the com port.

yes if i plug the usb i hear the correct digit and the first time he has install drivers.

You can try this procedure:

with arduino 1.6.7, when i try to add the library, he says that’s not a correct zip file, bu no problem, he add it on arduino library folder.

i have uploaded eeprom_clear with success.

after that i have try to upload grbl_upload, but i have an error at the end of upload.

but if i open serial com at the correct baudrate, i have the grbl help , it seems correctly uploaded…

i have started firefox… ho i hear some electric signal in my motors… YES that’s it ! i can move X axis, Z axis… Y axis seems to have a problem. He don’t move properly… i click “NO”, i try to return to the setup process, and now nothing seems to be working…

i restart all of hardware without success…
i’ll retry tomorrow

Contact our support team and they can help you get this fixed.

i have found the problem !

i have retry a flash of the arduino from another computer. without error this time. but still not work…
finally, i have try with a “made in china” arduino uno compatible that i have instock.
and all works fine now with it !

my x-carve move, easel see it fastly, and my only problem is that the automatic spindle work during the test, but not when i try to do the final carving test.

but i’ll search why later !

about my non fonctionnal arduino, there is a warranty ? i’m in France and shipping cost for return are soooooooo expensive !

I think I have a similar problem, not sure. I have just finished building my 1000 x carve and when I tried to do the machine setup my laptop (running windows 10) doesn’t recognize the machine. I looked at some posts and tried disconnecting the gshield from the arduino. Now my laptop recognizes the arduino but when I reconnect the gshield it doesn’t. Any suggestions?

yes, it’s same on mine.

to day i have tested to communicate with the official inventable’s arduino and that works ! but only without gshield pluged…

my functional arduino works with an ATMEGA328P-PU

this one with an awesome tiny version of this chip (i suppose)

some news … today it’s my chinese arduino uno who don’t wants to carve…

i have changed the cable without success. it really appears that the problem is on g-shield… i’ll try more experience this afternoon .

i think there is a big problem inside easel local…

i have made this test on 3 PC.

PC1: netbook HP on win 7 starter
PC2: portable PC DELL on win XP pro sp2
PC3: Desktop PC on win 7 ultimate ( a powerfull PC)

test: attempt to connect arduino (official and chinese) with or without gshield pluged…
No other cable than USB pluged.

see the results:

first time i supposed it’s probably an electrical problem, maybe too much power needed on portable devices but after some measurements, this way is exclude.

it’s probably a software problem of communication on the serial port by easel local.
but why sometimes that’s works and sometimes no… i don’t know !


PC2 with chinese and gshield has crashed during the test process…

aaaaaaaaaaaaaaaaargh what a bullshit i have bought !!!
i’ll take another last PC… a biger laptop with win 7 ultimate (yes i can’t use my desktop with my x-carve, there is too much distance between them …

the last pc seems to be the solution…
my x-carve is carving my resin clamps

it appears with these test that windows XP or seven starter are not completely supported by easel local.

problem reappears !

after milling my clamp 3 days ago, i would start a new piece… and easel says “don’t see your x-carve”… shit !

the problem of OS is probably not the real problem. the real problem is about serial communication. The pc see the arduino and com port but can’t connect to it. with easel or arduino software…

if it try to connect the arduino who doesn’t work on PC4 to PC3. the PC3 see him and easel start correctly.

after that, if i try to reconnect on PC4, he still doesn’t work.

delete and reinstall drivers of arduino doesn’t work

install easel local reactivate the com port availability in arduino sowtware

reinstall easel local reactivate the communication on easel and my x-carve is now functionnal…
but for how many times ?

I now sure that the problem is easel local !
and i must precise that the PC4 as never reboot between when it work and when it doesn’t arrive to communicate…

This really sounds to me like the arduino and g-shield are not tightly connected and causing random errors. I would check that the g-shield is tightly connected to the arduino with no stray wire strands touching where they should not be touching.

the g-shield is not the problem. when that doesn’t work, i have tested to communicate with the arduino outside the box with no gshield plugged… without success.

normally, that should work.

the only way for the moment for me is to uninstall/reinstall easel local.

It seems to be a known issue with the new version of Easel Local and Windows 7. One my machine it looses communication if it goes to sleep. The solution is just to reboot. This is Win 7 on Chrome.

i have also try a reboot without success.
And my machines never sleep. This mode is is unactivate at my home.