New Xcarve won't connect

Hello, I just finished the build of the 1000x1000 Xcarve, the build went well but I can’t get the Xcarve to connect to my Macbook Pro. I downloaded Easel sender which I think are the drivers. I can’t seem to open the driver package, it just keeps reinstalling the package. D0 I even need to ever open this? Also, I can’t really see the green light that is supposed to be lit on the front but I can hear the fan running.
My 3D printer required me to install Arduino on my PC and I have seen nothing about this in the directions. Is this a necessary step?
I am running El capitan on a new Macbook Pro with one usb port.


Grab your estop “big red button on top”. Give it a twist and a solid pull upwards. It should make a sharp “snap” sound when it ingages or disengages. This has stalled a lot of people here. That’s probably your issue. I know it got me lol.

1 Like

Thanks! I will try wen I get back to the shop tomorrow. Not sure why I didn’t think of that! I’m hoping this is the problem…

1 Like

No problem. It took me a little while to figure that out. If you just twist it like it shows then it doesn’t seem to work. It needs the help up lol.

There is a green LED on the front plate which will be lit when power = on and E-stop is not engaged.
No LED but power = off => E-stop most likely triggered

Thanks for the help guys! I went back and tried last night… and that was the problem. I cant believe I missed that!

Awesome. Glad It worked out.