Newbie quesrtion

I am building a Bulkman 1000 x 1000 CNC that has an Arduino nano as the control unit using high current grbl to control nema 23 steppers. I cant get easel to recognize the machine. Has anyone tried this and succeeded? If yes, please help. The spindle is a 1.5 kW air-cooled drive controlled by a VFD. I appreciate that this shouldn’t matter but i though more information might help. I also tried moving the steppers in universal g code sender with no luck. I’m just not sure what i have screwed up here.

Does your computer make a chime when you plug in the Arduino?
Can you connect the Nano, by itself, to the pc?
Can you connect to the nano with the arduino IDE?
Did you upload grbl firmware?

1 Like

Hi Neil, thanks for the response.

Yes my PC does chime
Yes I can connect to the nano with the Arduino IDE and I have uploaded the grbl firmware 1.8.15

No luck

Not sure about this.

Connect through Arduino, open the serial monitor and change the baud to 115200.

What happens?

1 Like

Thank you both for the feedback. Here is my latest update. I have managed to get UGCS to talk to my stepper motors via the Arduino Nano. However the stepper motors seemed to be taxing and there was a lot of really bad jitter and noise from the whole CNC. As usual I blamed myself for the build, so I dismantled the x, y screw threads realigned the rails and replaced the threads. Same problem exists. Being reductionist I decided to see if I had screwed up the motors. I happened to have a homebuilt stepper motor controller from several years back that uses a manual PCM circuit to control movement and direction. When i wired it up to the X axis motor it worked perfectly. So I reconnected the x axis thread and the movement was smooth and noiseless.
My only conclusion is that there are settings in either my TB6600 output dip switches that are wrong or that the gcode i am using is incorrect.
Following Seths advice i followed through the video instructions and the baud rate is 115200 etc, i installed ftdi just in case that was the problem with easel. When in looked at the advanced machine settings in easel I got the following machine settings. Im afraid they mean very little to me, but easel can talk to the CNC now but the movement is not smooth and very loud.


Any suggestions as to what I should try next? Thanks very much for your patience and help.

Cheers, Don