No Black Dot

When prepping my file and cutting I never saw the black dot at work zero, or anywhere. It ended up cutting a little off centre.

I am using a 3018 DIY machine. I turned on my machine, edited my file a bit, pressed carve, manually jogged the machine to the start position i wanted. Everything was measured properly but for some reason it cut off centre. I am not sure if this was related to my not seeing the black dot at 0,0.

I am very new so any help is appreciated!


Did you ‘home’ your machine first? Homing establishes the starting point/reference, usually in the lower left corner, for where everything else is calculated from.

Thanks Traxxtar

I don’t believe I did this, but i don’t think it asked me. Can this be done manually when highlighting the shape and in the icon that shows bottom let corner manually putting X and Y to 0?

Can you recommend a step by step for easiest way to do this? I am using a laptop and don’t have an offline controller or anything. Do I always have to set the machine up first and plug in/turn on before starting a new project? I have been doing it on the computer first and then plugging in setting up machine and turning on.

CNC machines need to be ‘homed’ so they have a reference to start from. This is done by having homing switches installed and then you run the homing sequence. After the machine is homed, it then knows exactly where the spindle bit is located and can cut/carve from that point as a reference point since it then knows exactly the location of X/Y/Z.

If you’re using Easel, you can design from any computer and then connect to your machine later to carve. You can also design using other programs and connect/carve when ready.

Is it possible to do this without installing homing switches? Is that something I need to buy that comes separately?

You don’t need homing switches unless you need to have a repeatable position (really useful).

How and where did you set zero? How far off is the actual carve? In what directions?

The more detail you provide, the easier it’ll be to tell you where it went wrong. Homing switches don’t make a difference in this case.

i manually jogged the machine to the bottom left corner of my material and in settings hit G92 to manually set x and y to 0
the cut came out a 1/2 inch higher and 1/2 inch to the right of where i thought it would be

Are the left and bottom of your design at exactly zero for X & Y? Also, remember that the Zero for X & Y is at the center of the bit, so take that into consideration as well.


Brandon Parker

1 Like

Directly over the corner, with the bit centered on the corner?

yes it’s a really small bit only 0.1mm.
i think it has something to do with my material not being in the bottom left corner of my table.
i use clamps so have the piece of material closer to the middle of my board.

i thought none of this matters as long as when i go though the sequence after pressing carve i jog the machine to the lower left corner of the material?

is this what setting work zero is? i am a bit confused with setting work zero and homing. i never receive any promts to home the machine. i dont have any limit switches or z probe or anything like that.

Hi Brandon
Sorry how do i know if the bottom of the design is at zero?
i have a word that is centered in the middle of the piece of wood and i jog the machine down to bottom left corner of material.
it seems to be moving to the area it should generally but it’s just off by a half inch

Homing doesn’t matter if you don’t have the switches installed. Don’t worry about that.
The only thing you need to be 100% sure if is that your work zero in your CAD/CAM software is the same location as what you actually set on the workpiece.
Can you share any files? What software are you using? How big, exactly, is your stock?
How are you measuring the half inch?
Aside from being offset a half inch, are the dimensions of your work accurate?

When you highlight your entire design in Easel, you can click on the “Shape” tab on the floating window. Ensure the lower left position selector is selected. Then you just set the X & Y to 0.0.

When you set the Work Zero you need to ensure it is where you expect it. Moving the machine after you set the Work Zero does not change its position. You could move it all the way back and to the right and it would not change.

The dots in the image are where you set your Work Zero with how the Easel setup above is shown. When you shift that back and right, you get the red cut …


Brandon Parker

Here is what I did.
Everything is accurate except it printed closer to the top right of the wood.
I am not seeing the black dot at 0,0 that was part of my question as everyone else seems to show that in their videos.
My shape isn’t at 0,0 because the word is centered on the material, is that correct?
Because I’m using clamps my wood isnt exactly on the bottom left of my work area.
is there a way to show the preview of the red and black or did you manually render that?
thank you guys so much!

Is your stock exactly 150mmx94mm?

If you jog 100mm, does the machine move EXACTLY 100mm?

I just made it in Paint …

So, the word “Mabel” (interestingly this is the name of my wife’s childhood rocking-horse) carved correctly but in the wrong place? If yes then continue …

If your stock is that size and you are centering the lettering on the stock in Easel then you MUST place confirm your Work Zero at the absolute lower-left corner in order for it to cut out the word where you depict it in the design. If you set your Work Zero back and to the right then your word will be “back and to the right” by the same amounts as your Work Zero. Tool paths are calculated from the Work Zero position.

So, if you have your design laid out as such and then set your Work Zero 50mm back and 50mm to the right of the lower-left corner of the stock then your word “Mabel” would be located at Left X = (40 + 50) = 90mm and Lower Y = (35’ish + 50) = 85’ish mm ('ish because I can tell where it is exactly :slightly_smiling_face:)


Brandon Parker

So my stock is the exact sizes yes, and when i jog the machine, it is moving properly.

It sounds like i am setting work zero improperly from what you guys are saying.

When and how exactly should i be setting work zero in easel? Is it once i press carve and jog the machine during set work zero to the lower left corner when going through those first prompts? At this point?

Is it possible something about my settings is causing this? The last one I did was even more off and went down and off the wood and i had to stop it. I have absolutely no clue what it was doing since the word was in a straight line.

Try this: Setting workpiece zero