No Communication

Ive had my XCarve for about a month. Im using Easel Pro on a laptop with windows 8. For the first two weeks It worked great no issues. Last week it started loosing connection during a carve and I would have to reset. Last Friday it carved a gouge through the middle of a carve and has not communicated since. I have left messages (phone and chat) for Inventables with no response. I have tried multiple USB ports, reinstalling the driver and anything else I could think of. PLEASE HELP!!!

Hi Charlie - our Customer Success team is available Monday-Friday from 9-5 CST. They try to respond within 1-2 business days at the most. If you reached out on Friday and didn’t hear back, I’m sure they’ll reach out today or tomorrow, but I’ve let them know about your post!

Well, they have had 10 days…plenty of time. Also you may want to consider expanding your hours. Most hobbyist have daytime jobs and only use this in the evenings and weekends. I will wait for someone to contact me.

Do you get the little chime when you connect the USB?

No, the ports work with other devices but not the xcarve

Have you tried connecting straight to the controller, using the micro USB on the main board?

I checked the connection to make sure it didn’t come unplugged but didn’t try connecting direct, thanks for the suggestion. I’ll try it.

Once I was able to get a support person they were able to quickly identify and resolve the problems. First I had a com port issue that they were able to fix. The other was most likely contributed to my router and controller being on the same power strip causing power fluctuation. It is communicating for now, fingers crossed!