Inventables Community Forum

No connection to 3018

Hi folks.
Just joined as I’ve bought a 3018 CNC router.
After spending all day getting my head around the Easel software to the point of sending my test piece to the machine, when I press the ‘Carve’ button, I get a window saying I need to install the Easel driver.
I’ve installed it three times now, but it still comes up every time and won’t connect!
Any ideas?
Thanks.
Andy.

Call Inventables tech support

Not from the UK, that would cost a small fortune. :slight_smile:
Do you not have an online help chat ?

This is a community-driven forum :slight_smile:

Have you tried a different browser and/or PC? This do sound like an issue on that end.

For best possible response you can check out the following link - https://www.inventables.com/support

Hi.
Tried another browser (Brave) as against Chrome, and another pc, both running win 10, still won’t connect. Thanks for the suggestion though.
Andy

I had the same issue and just fixed it. At least for me. Go to Help>Troubleshooting>Machine won’t connect. Select item #6 Network Settings. Select the hyperlink to “try disabling HTTPS”. Set up the machine again and when you click the carve button you will get a window that allows you to manually set the COM port. Worked for me.

Cheers James, I’ll give that a try tomorrow.
Thanks.
Andy.

Hey James!
Cheers matey, that sorted it!
You’re a star! :smiley:
Andy.

Happy to help