Inventables Community Forum

No connection

Greetings
I’m working with X-Carve 100x100, with X-Controller and easel local 0.3.18.
For unknown reasons the “Carve” button in Easel remains blue.
I have tried with multiple restarts (both controller and pc) as well as with reinstalling the driver, but without results.

Funny thing, UGS works, so at least I can export gcode from easel and work in UGS, but I’d like to resume working with easel alone without export/import.

Can anyone help?
Thanks in advance.

Make sure you don’t have UGS and Easel running at the same time. Only one connection is available at a time, so if UGS is running and connected, Easel cannot make the connection.

2 Likes

Hi AlAmantea,
thanks for the tip, I’m sure it will be helpful for anyone who reads this thread, but I already made sure of that.

I have located easel local logfile, and it is running and listening for connections (also made sure it was running under services.msc).

Tomorrow I’ll try to debug the network traffic of the browser and see if there are errors/timeouts while connecting to localhost…as well as check if there are connection attempts.

In the browser I have found multiple connection attempts to this address
https://inventableslocalhost.com:1438/socket.io/?EIO=3&transport=polling&t=N1zSEHs

Problem is that I cannot resolve it.
It should be the local easel driver service but it does not work.

I really do no know how to solve this.
I have tried reinstalling windows and drivers but without success.
I have tried installing linux, and driver, but without success.

Again only Easel is not working. UGS and other software are fine.

Can anyone help me?
Thanks

I have contacted the support and received this email from Giovanna Diaz Fabiani

Hi Geo,

Thank you for your message, I apologize for the trouble. When you click the Carve button, what message do you receive? That Easel cannot find your machine or to install the Easel driver?

Which version of Windows are you using?

If you are planning on working with Easel alone, have you tried removing UGS from your computer?

I would recommend restarting your computer and only turning on Easel. You’ll also want to make sure your X-Controller is fully powered on and the e-stop button is disengaged. We may need to reset or re-flash your firmware. However, we first need to confirm your X-Controller and computer are communicating. Does the X-Controller show up under Ports in the Device Manager?

If so, take note of the COM number. If you see multiple COM numbers, you can try unplugging and plugging in the X-Controller to confirm which one. This is the COM port number you’ll need to specify in Easel.

I’ll be waiting to hear from you and we can go from there!

Sincerely,
Giovanna

Here my reply

  • The Carve button prompts me to install the easel driver, the same as the “Setup your machine”
  • I use Windows 10 and tried with Ubuntu 19.10
  • Having UGS installed or not does not make any difference. Also if I test UGS I keep the browser with Easel closed, and viceversa
  • Computer has been restarted multiple times, with the same results.
  • X-Controller runs fine with UGS, e-stop is up
  • Connected to COM3, in Easel I have no way to specify the com port

Additionally the Easel Local port 1438 is open, if I telnet localhost 1438 I can connect… but not much else.

Regards
Geo

Since Easel is browser based, and UGS is a local run, try turning off your firewall temporarily to see if the culprit lies there.

Greetings to all
I have found a solution, which looks more as a workaround but it works.

I have edited the file “C:\Windows\System32\drivers\etc\hosts” (with admin rights) and added the following line

127.0.0.1 inventableslocalhost.com

For some reason the easel local hostname was not registered (I don’t even know where it could be registered, maybe in the Windows firewall? but then what about linux?)

Best regards
Geo

2 Likes