No motor movement upon setup

Hey guys, I just got my machine built and looking beautiful. I started to do the setup with easel and none of the motors were responding. I’ve double checked all connections, made sure the arduino and shield were completely mated, and even flash the grbl onto a different arduino and it still won’t move… Is there a way of telling if the G-shield is working? or is there a way to make sure the arduino is working properly?

I have opened the serial port on the arduino with the IDE and it says something like “grill 0.9j “$” for help” but if I send “$” I don’t get anything back. Let me know if there are any suggestions for further narrowing the problem.

Are there any lights lit up on your g-shield? I’m assuming it has allowed you to connect since you’ve gotten as far as testing the motor direction.

Can you post a picture or two of your motion controller set up?

With the USB cable plugged in to power the Arduino and gShield logics, and the 24 volt power supply turned on you should have the blue LED and three green LEDs on the gShield lit up.

If not check you wiring to the stepper motors.

I just get the blue light, but my wiring is sound.

Also I’ll try to post pictures tomorrow, but I believe everything is all done to spec.

Ok. The next possibility is that the gShield is not mating properly with the Arduino. It’s pretty easy to misalign them.

If that’s not it then the next thing would be a problem with the Arduino.

Use the serial monitor in the Arduino IDE to get the grbl parameters from your Arduino. Make sure that your computer port is set to 115200 as the baud rate. When you get the grbl version printout in the serial monitor issue the $$ command to get the parameters and post them here.

Here is screen capture. I’ve connected to the arduino just fine, but the serial monitor doesn’t show a response when I send ‘$’ or ‘$$’. I have tried this on 2 computers, both windows and mac, and with 2 different arduino unos. neither show a response? is the 0.9j good?

I use grbl 0.9j and it works fine, however, when I tried to load the hex file on the Inventables website it would not work for me. I downloaded the source, compiled it and then uploaded that and it worked fine.

Change the “No line ending” to “Newline”

Here you go! Thank you for the help. I hope this leads to something lol.

This is the arduino that was sent in my X-Carve kit. I haven’t touched this firmware.

Those values are good. This says that the Arduino is functioning on some level. Do you have the homing switches installed?

Yes. I do.

Ok, just as a test make sure the power is off on the 24 volt supply and unplug the USB connector to the Arduino.

Remove the connector on the gShield that has the homing switches and spindle control.

Bring power back up (USB and 24 volt) and see if you get the green LEDs.

still no green lights…

I guess it’s picture time. With the power off (USB and 24 volt) hook the homing switch connector back up. Take some pictures that clearly show the wiring on the gShield and the wiring in the homing switch connector and post them here.

At this point, it’s beginning to look like you might have a defective gShield.

I’m sure some of these are redundant, but I was trying to clearly show every aspect. also I know my homing switch connector is a little janky lol. but all the connections are good. Let me know if you want to see anything else.

Thank you!

That all looks good.

One more thing we can try to see if the gShield is at least partially functional.

Use your terminal program to change one of the grbl settings

This will tell grbl to output the Machine co-ordinates, the Work co-ordinates, and the value of the homing switches.

The Machine and Work co-ordinates will be meaningless at this point, but I want to see if the Arduino/gShield will read the state of the homing switches.

After the above change enter the status command, which is the question mark ?

One of the output values will be LIM=000 if you have wired the homing switches to be normally open.

Press one of the switches, hold it and do the ? command again.

The order is LIM=ZYX so LIM=001 would say that the X homing switch is triggered.

You might as well test all of them while you are doing this.

If that works as expected I would recommend that you contact Inventables and see if they will send you a replacement gShield.