No power on X-Controller, fan working, no machine movement

Hi All

Your help will be much appreciated as I’ve tried a number of different steps but can’t get my machine to operate.

My X-Carve 500x500 belt drive was working fine a few months ago the last time I used it. It is less than 6 months old and I used in a few smaller projects and I’ve not changed anything since the last time I used it.

I recently tried the machine for a new project, but I can’t get the machine to move. When I power it on, the fan on the controller comes on, then …

  • sometimes the Power led on the back comes on, but other times it does not come on
  • the Power led on the front does not come on.

I’ve disassembled and reassembled the controller, but still get the same issue. I’ve also re-checked the motor wiring. There is no movement from the machine at all when I issue movement commands or attempt homing.

I’ve checked the E-Stop in both settings. The drives jolts when I initially switch it on.

I attach a screenshot from the MI.

Thanks in advance


deleted…you answered my question.

Hi Ian7,

I’m new to the X-Carve community and have just finished assembling my x-carve and was trying to connect my X-controller to easel for the first time. I’m having the exact same issues that you are having as well. The power LED in the back of the controller is on, but goes off at times. The fan comes on, but the power LED on the front is not coming on. I’ve checked and double-checked the E-stop, and taking my controller apart to ensure all connections are correct.

After entering my machine’s details in Easel it just doesn’t seem to recognize it at all. I, however, am on a mac running OS version 10.15.5. Have you found a way to fix the problem yet? I haven’t been able to figure it out and I’m really looking forward to running my first project on my x-carve.


Running the 1000mm and just finished assembling the machine and I am having the same issue. My led light does not come on but both fans come one. Computer will not see the machine at all.