Not a good day of carving

I’m a bit bummed out.

I’m learning how this machine works, and I know that along the way I’m going to hit speedbumps and get frustrated. This is one of those times. Please allow me a bit of space to vent, and if you can offer any advice, it is welcome.

So, I managed to get Grbl Controller 3.6.1 running pretty reliably on a Raspberry Pi 2B. The only trouble is that it seems to like to over-write the config settings at random. First it set hard limits to “on” which caused the spindle to come on only for a split second before the electrical interference made it think it hit a limit switch. Then, it decided to replace the values for $11 (junction deviation) and $12 (arc tolerance) with 0. This made my machine step in a chunky, notchy way as it was doing curves.

I really want to get a bulletproof setup on the Pi, because I don’t want to run my MacBook Pro in such a dusty environment. But, it’s beginning to prove more trouble than it’s worth, especially as I’m learning about the physical workings of the machine. I don’t need software gremlins to deal with in addition to hardware ones.

Speaking of how the machine works…
I’ve been trying to carve a piece all day today and have pretty much failed completely.
It didn’t seem like such a hard piece, but now having gone through it, I can see what was going on.
The piece was a vent return cover, 14"x10" red oak.

I started by cutting a 1/4" x 10 x 8 relief into the wood with a 1/4" 2-flute upcut bit. The first time I sent the file I forgot to change the bit in Easel, so it thought it was a 1/8" bit and was going to take forever. I also forgot to offset the design for the width of the “frame” so it started at 0,0 rather than at 0,1.5. I cancelled the job, remade the .nc file with the right information, flipped the work piece over and sent it again. It still took a couple of hours to hog out. The bit was Super Loud and there was tons of chipping out and blown out edges all over the place.

Then, I switched to a 3/8" core box bit (essentially a cove bit without a bearing on top). This gave the edges of the relief a nice radius at the bottom. That didn’t take too long and fixed most of the blown, chipped out edges the 1/4" bit left.

Next it was time to mill out all the pockets for the vent. Like 465 of them. I didn’t really give it much thought at the time, but when Easel generated a 25mb .nc file I figured I was in for some torture.
It started out ok but it was going very very slowly. I guess it was an average speed for the machine, but the projected run time was more than 10 hours. So I killed the job because it was getting late, after about 5%, and decided to start over in the morning.

(here’s where I wish there were a way to pause a job and resume it later, or run the g-code to a certain point and pick up from there).

When I started the job again it was mysteriously about 1/16" offset to the right. I nudged the wood over while the machine was carving air and got it lined up again. This time it got about an hour into the job before it broke a bit.

Somewhere along the way the config problem with $11 and $12 happened, so I started freaking out about how the machine was running. It seemed to cut the shapes out fine but it sounded terrible and I imagine the jerkiness of how it was cutting was part of what broke the bit. I started adjusting the eccentric nuts, tightening belts, etc. Eventually the X belt slipped and caused the machine to sit there moving back and forth but not left and right, carving a nice notch into the piece. I decided I could live with that and persevered. New bit, heat shrink on the belt, eccentric nuts just right, everything should have been going fine.

I also decided to change the full-pocket operation to an outline operation and I also compared the file to what had been completed already and erased the appropriate holes. This made the file a much more reasonable 5.3mb. Still, I was less than 10% completed with all the holes.

The machine was running ok, still jerky (hadn’t figured out it was a config setting yet) but clean, and much faster. But, now I had to babysit the machine so that the centers of each pocket wouldn’t go blasting out or get caught. I had figured out a way to rig the vacuum cleaner nozzle to the spindle such that it would grab the tiny centers out before they caused trouble. As soon as I turned my back to get the zip ties, a chunk caught in the bit and broke it.

So, now here I am. I’ve got this piece that’s like 15% complete but I’m something like 10-15 hours into it. I broke both my 1/16" bits so I cant’ finish it until I order more. But, I’m kind of at a place where I don’t want to finish it anymore. Maybe I’ll revisit it in a different way another time, but I might be over this project and wanting to do something else. But, given how discouraged I am about the whole thing right now, I don’t even want to think about what else I can do with the machine.

Thanks for your time if you read this far :smile:

1 Like

I can understand your frusturation, I’been having hard time at the beginning with my Laptop as well. I have not much knowledge about Raspberry PI capabilities. My laptop was top notch i7 processor with 1 TB HD and 8 gig memory. Wasn’t enough for serious CNC communication because limited to USB power already build for Mobile operations. I read many articles and follow forums, all have same problems with mobile devices. I decided to go serious on this operation and purchased desktop PC with i5 processor, 500 Gb solid state drive and 16 Gb of fast ram running on ASUS Pro series motherboard also have USB 3.1.
I don’t know if I can tell you something. You’re almost done investing biggest part, my suggestion is to take it seriously and control your CNC with ease.
So, your other machine related problems goes away timely manner. Just follow past posts to see what everyone doing for belt problems, feeds and speeds.
I think you’re diving too fast and running fast. Try shallower cuts and lower feed rate all the way down until you find safe heaven. If you can find one of my post about belt solution try that. I have no belt slip what so ever.
If you’re using Easel, go over all tabs to see how can you change defaults for your need. And don’t give up. We all had all kind of difficult times at the beginning. There is no CNC equipment start running as soon as you crank it. They all need adjustments first. Good luck.

1 Like

Hey Mike, I’m really sorry to hear you’ve having all these problems. There’s a night-and-day difference between having to go out to your machine, wrestling with it, and never knowing the kind of result you’re going to get, versus having everything running smoothly and having the confidence that it’ll run exactly as you expect.

Did you get your machine squared up and tuned using your MacBook? I’m hoping to eventually migrate to the RaspPi route using Chilipeppr, but I wanted to go with a simple setup first. I’m using an old laptop that I had, and everything seems to be going pretty well with it, so it might be time to mess with things :smile:

Is there another app you could use on the Pi, like maybe UGS, to see if it overwrites your settings as well? Also, I’m guessing that if you’re on a Pi, you aren’t afraid of a bit of software complexity. Something you might consider is getting your grbl settings back to what you want, and then flashing a custom build of grbl that removes the ability to change the settings?

I know how frustrating a finicky machine can be, but if you stick with it, I think you’re going to be really happy with what it can do once everything is dialed-in. Hang in there!


Yeah I setup and tuned everything using the MacBook and cut my first few items with it. Everything went like a dream.

Then I started messing with the Pi and things got off the rails. For one thing I’m mostly a Linux newb. Now, I’m an OSX veteran, so the command line doesn’t really scare me that much. But, I’m not fluent and I prefer a GUI. But the Pi is so simple and bare-bones that lots of things just don’t have a setting in the GUI or aren’t possible that way. And, since it’s a custom Debian build with a non-intel chip, lots of things require being recompiled before they can be run. I guess that’s part of the philosophy of the Pi, learning to work with the computer and working within limitations. I haven’t tried ChiliPepr yet, and at first blush couldn’t get UGS to run. I think I might just keep using my MacBook and repurpose the Pi for something else.

I was really happy with the results of my first few cuts when the machine was working properly, and when the software wasn’t being an ■■■■■■■. I’m pretty sure I’ve dialed the machine in as far as I can in terms of getting things like the wasteboard aligned with the 0,0 point, setting the limit stops for repeatability, squaring/truing the rails and axes, so if I can just get remotivated to keep cutting I’m sure I’ll be fine.

Thanks for the encouragement, it really helps!


Hi Mike,

While I can feel your pain, I can’t offer a lot of advice with specifics to your configuration because I use LinuxCNC on a small, older Dell Optiplex 755 (core2duo). What I can suggest to you is to stop and take a step back and think about all the pieces that have to work perfectly for this thing we all call “cnc” to work the way we want. Calculating the permutations of things that can go wrong would be astronomical. @AlanDavis is right, and it pays to take things slowly sometimes.

A good friend of mine and I will talk from time to time about how some aspect of the latest tech thing, say your smartphone, is driving us nuts! We may have tried everything to get things working the way WE want, but to no avail. We have to remind ourselves from time to time that these things are complicated. The old saying, “Its not rocket science” is not so accurate these days I think, as most of the things we do are all quite complicated at their core. We can take this for granted, I know I do.

I had a similar experience with the Shapeoko 2 when I first got it going. My thought from the start was to run LinuxCNC, so that’s what I tried from the start. I had tons of problems, and no real thought through plan of attack. Just make it work! Well long story short. I went back to square one. I disassembled the Shapeoko 2, putting it back together using Locktite this time, a machinists depth gage, and various indicator dials to get things as perfectly aligned as my tools would allow me to.

Then I put the LinuxCNC stuff on hold and started with the Grbl Shield and the Arduino. I spent probably a week getting everything working reliably. I literally created a 3-ring binder, documenting every connection, wire, and software configuration, so if I had a problem, I had a place to go.

Fast forward about a month, I then started working on LinuxCNC. I have had some experience with the program in the past, and I’m well versed in Linux, so this mostly went ok. The important thing for me was that, I knew everything was working and accurate, so when problems would arise, I roughly knew where to start looking. This second time around went much better than the first. I even updated my 3-ring binder to reflect the migration to LinuxCNC.

Lately I’ve been eyeing a fork of LinuxCNC called Machinekit, which runs on the Beaglebone Black, and makes use of the co-processor on the BBB to offload step/direction signal generation. The temptations run high but for now I resist. My X-Carve upgrade kit shipped this week so it looks like I’ll be starting from square one again!


If you have a swap meet or flea market they sell old small computers and they are cheap.
Look for a cheap box that fits the requirements of the software. Me I have a small Acer box that could serve as a system to work with. Computers can work fine in a dusty environment. As long as you let them breath and use filters. A small wooden enclosure is not too hard to build and most who are getting these devices have a garage or workshop to work out of.
Good luck on your future projects. I had similar frustration with 3d printing.