Not able to Control Laser intensity

Good Afternoon All!

I’ve got the 1000mm X Carve that I just ordered about a month ago. It’s up and running successfully. I just added the 3.8 Jtech laser to it’s capabilities. I’ve got it wired to red wire PWM Spindle Control, and black wire to the spindle control Ground. I have the front switch of the laser driver set to TTL control, not CW. I am able to turn the laser on and off with M03, M03 Sxxxx and M05 to turn it off. However, the laser always burns at full intensity. Reading the Jtech instructions for focusing, I should be able to set the laser to run at a much lower power in order to focus it.

XCarve 1000mm
X-Controller with GRBL 1.1f
Universal Gcode sender to control
Red Wire PWM SPindle
Black Wire GRN
Switch set to TTL

Am I missing something? It was my understanding that this version of GRBL should support lasering.

Thanks for any and all advice :slight_smile:

What are your $30 and $31? They have to change for laser to be $31=0, $30=255 if I remember right.

EDIT Not $21, $31…sorry was on my phone.

1 Like

There are rules for using a laser with 1.1f.

You can read them here.

There is a simple solution if you want to use standard G-code.

1 Like

Typo it’s $30 and $31.

This is what you would do using my 1.0c version.

1.1f doesn’t have the same limitation, you can use any range that you want to with 1.1f just like you do for the spindle.

1 Like

Sorry, was on the phone. Thanks for pointing it out Larry. Fixed the post.


I had tried $31 for both 1 and 0. When set to “0” I could contrrol the laser on and off. When set to “1” I was unable to control the laser. I had read the documentation, and assumed it was because the machine wasn’t moving.

I had not messed with $30 yet though, so possible that that’s my issue?

Also, thank you all for the responses. I’m still getting the hang of everything, But between Inventables, this forum, and Jtech Support, I’ve had nothing but positive experiences :slight_smile:

So the way it works is the output is a range of 0-5V.

$31 sets the minimum RPM value that equates to 0V.
$30 sets the maximum RPM value that equates to 5V.

If they are set to 1 and 0 ($30=1, $31=0), the output works like a switch. On and off only. This is probably what you’re seeing.

If you set $30 to a higher number, now you’ve got what could be considered a dimmer switch. Every value increment between 0 and the $30 value, increases the output voltage by a certain increment. If $30=5, setting a 2 would mean a 2V output.

Read the Wiki page that Larry linked to. It’ll help.


I would recommend that you change to my version of grbl if you don’t need the spindle speed and feed rate over ride functions of 1.1f

It’s just much easier to use.

What you can do with your present system. Is pick a range for spindle speed, with my firmware it’s 0 to 255 ($30=255, $31=0) for 1.1f you could pick anything say ($30=1000, $31=0).

For my firmware you would use the following command to turn the laser on at 50 precent power.

Laser on at half power M03 S128
Laser off M05
Alternate laser off S0

With 1.1f
(read the rules there are many options here’s one)

First time Laser on half power G91 G1 X0 F1 M3 S500 followed by G90 next command
Laser off M05

Following times laser on M3 (unless issued after a G0) then you need to do First time laser on

Alternate laser off S0
Alternate laser off G0

1 Like

Yep, I will give that a try as soon as I get my son to bed tonight.

Thanks again for all your help! I did try and search for this answer beforehand, but most of the issues I saw centered around it not working period.

Appreciate it! :slight_smile:

1 Like