Not Connecting to X-Carve

I know this isn’t a new topic but I haven’t found my answer.
It worked fine last night but today nada.
Blue carve button – no green joy. I’ve reinstalled the driver several times because that’s what Easel keeps telling me to do.
UGCS machine controls work fine.
I even turned it off and then back on.
Any ideas appreciated.

Well if that was it then wouldn’t the ugcs not be able to communicate as well?

I’ll give it a try.

Have you done the full power off on xcarve and computer? if yes then I would try to clear the cache memory on the browser. It would probably be something holding the port from a previous connection.

Yep. Did that. No help as yet.
I have noticed in the past couple of weeks that sometimes it was reluctant to “go green.”
But it did.


I have since reinstalled Easel Local and flashed the Arduino. Still no help.
I guess I’ll call in tomorrow.

thanks all

I am also in the same boat as of the update that I was prompted to download last night. Please let me know what you find.

WIll do.

I called in to Inventables today and we tried everything we could think of and finally came to the conclusion that the Arduino had gone stupid.

Another one is on the way. Fingers crossed.

And I must add that Inventables’ customer service is IMHO stellar.


I always uninstall the previous version of software before installing the new. Things can get hosed. When problems arise,

  1. Unplug cables
  2. Reboot the computer
  3. Uninstall the previous version of software
  4. Reboot the computer
  5. Install the new version
  6. Reboot the computer
  7. Cross fingers and/or pray
  8. Plug in cables
  9. Test
  10. If successful, exhale.