Not finding com port

just setting up my x-carve 1000mm and its not finding the com port, getting the circle of death.

What is getting the “circle of death”? Are you trying to run Easel? Did you install EasyLocal?

I’m following the build instructions on line and just powered it on and using the machine setup with easel. I was able to move the steppers using the arrow keys and they all move in the correct direction and progressed to the machine setup. After that it wants to know the com port, that is where I’m getting the circle of death. After thinking about it if I’m able to move the steppers with the computer it must have found the com port, so maybe I’ll just ignore it.

Having the same issue now.
I had the machine up and was ready to cut the first test with easel, when the com port stopped working for some unexplained reason.

Tried disabling the comport through computer management in windows 7, didn’t work.
Tried to update the drivers, didn’t work.
Reinstalled the arduino software all-together. still no luck.

Some people have had good luck with using a powered hub for the USB connection. I’m not sure why this works as the Arduino/gShield don’t draw much power. I also have seen the COM port come and go.

I wiggle the USB plug on the arduino and I can hear it blipping on and off on my laptop. Do you suppose this could be it. When I go to control panel I see it available and listed on COM13.

Sure. I have a test setup where the USB cable hangs out in the air. I can make the connection come and go by tapping the wire.

Also, check your power settings on the laptop. Some devices get powered down without keyboard activity.

I had this problem. I updated Java, and it was able to find the com port. I’m not saying they are related, but they happened at the same time.

Also, see this possible upgrade- [Help us!] Testing automatic port detection on Windows

So I tried to run the X-carve with 3 different computers.

2 of them were able to connect, and only 1 (my laptop) was able to successfuly carve a few things.

After that, I tried to import a SVG file to cut.
I was not able to change the material thickness for some reason, and closed the project.

Wanted to start a new project, but now easel is not even picking up the X-carve. Just keep seeing the message " Make sure your machine is switched on and that the USB cable is plugged in"

Tried to restart the PC ( thought there was some process that needed closing) - No Luck
Disabled the power settings in device manager for USB’s - No luck.
Tried uninstalling and re-installing arduino - No luck
Tried uninstalling and re-installing Node.js - No luck

I have to say, running into such an array software problems, at first time use, is not very encouraging. Feeling like I have wasted my money quite a bit.

Please help?

Is the machine showing up as being connected at all anywhere on your computer? If so, try using another program to jog it around, or use a totally non-browser based program like UGS or grblControl.

Otherwise, if it’s acting like it’s not even plugged in at all, then it genuinely sounds like the USB connection in the arduino is bad. I would take it apart and examine it closely, try hooking it up outside of the enclosure/case and watch the LEDs and other behaviors. Perhaps a cold solder on the USB plug going into the arduino board itself.

I don’t know if this would cause the arduino to not respond to USB activity, but maybe the gshield isn’t seated properly?

Yes, this would cause USB connectivity problems. Most notably, the COM port will disappear in Device Manager in Windows.

1 Like