Not homeing

I just up graded my x-carve =with the tbd super grade direct drive z axis…
when homing the x carve want to go towards the back left instead of the left front
what can i do to solve this

Did you have any of the wiring off the x axes? Sounds like you may have turned some wires around.

If the wiring is all correct, I’d read $23 in the link below. It will refer to the chart in “step port invert” which is $2

You only changed the Z axis, and your Y goes the wrong way?
I’m guessing you changed your $3 setting.

Can someone help me with my homeing? When I get to the homeing sequence of setup, my x-carve moves forward and never stops. It just keeps banging against the actuators.

The homing sequence is as follows:

  • Move towards Z-switch, tap once, pull off, tap 2nd time.
  • Then perform the same for X/Y together.

If your machine move towards you during homing it it either misconfigured or a Z-switch trigger have been detected (incorrectly)

Do you use Easel?
If so, start it up, and go to Machine Inspector window. It will have three “switch LEDs” showing, press the homing switches manually and the “LED’s” will turn green.