Not seeing Arduino - "board at _____ is not available"

I sat down to do some cutting today and my computers (a Mac and a PC) won’t connect to my XCarve. It worked fine when I was using it last weekend and it hasn’t been touched since then.

I figured I’d try re-flashing GRBL but I can’t even access the Arduino to do that. On both computers, when I use the serial monitor in Arduino it says “Board at /dev/cu.usbmodemfa131 is not available”. On the board itself the blue LED is on, but the 3 greens aren’t lit up. And of course since Arduino doesn’t see anything, neither does device manager/system information.

In UGS when I try to connect it says “error opening connection ( Unknown Application”. It also mentions creating a /var/lock folder, which already exists - permissions set to 777.

The Arduino & g-shield are securely seated and I’ve hit reset on both.

Thoughts? Ideas? Voodoo spell suggestions?

Just a shot in the dark, but what happens if you try just the Arduino with no shield attached?

Just tried that and the serial monitor gives me the same “board at /dev/cu.usbmodemfa131 is not available”, BUT on the Arduino board there is a yellow/orange LED lit up by L and the green “on” LEDs is lit up too. So obviously it’s getting power…

Make sure that you have selected “Arduino UNO” or equivalent under Tools->board and the correct port in Tools->port.

Set your baud rate to 115200 on your serial port and in the serial monitor.

Arduino/Genuine Uno is selected in Tools > Board.

On my PC, Tools > Port is greyed out and doesn’t expand open. This is using Arduino 1.6.7

On my Mac, Tools > Port isn’t greyed out but the only options there are Serial ports (which does nothing when I click on it), Bluetooth incoming port & Bluetooth modem. The normal USB port isn’t showing up in the list. This is using Arduino 1.7.8

Is it possible that somehow my Uno board died somehow?

In Windows if you go to device manager, you should see the com ports show up when it is connected. If not, it is possible the Uno is messed up. Since it is happening on two different machines I would not suspect the driver, but anything is possible.

Have you tried a different USB cable just to rule that out?

Tried a different cable - no luck in it being that easy. :wink:

Device manager doesn’t show COM ports in the listing, although I know it should. It’s not that the category is empty - it’s literally not there at all. I turned on hidden items and still nothing.

My Mac doesn’t show the Arduino in the system report either.


[[quote=“MikePlummer, post:3, topic:20369”]
yellow/orange LED lit up

Missed this the first time. The yellow/orange LED shows activity on the serial port so if your yellow/orange LED is on but not blinking when you run UGCS then your serial line / port is not communicating with grbl.

Try re-installing the Arduino device driver in Windows.

I’ve reinstalled Arduino multiple times on both machines, and I’ve also uninstalled & reinstalled FTDIUSBSerialDriver multiple times on both machines. No luck - still no ports showing in device manager on the PC, and no Arduino in the system profile on the Mac.

I’m so annoyed because I was cutting fine last weekend and the PC hadn’t even been touched since then. (that’s my garage computer)

I’ll call Inventables tech support tomorrow and see if they can get me back up and running.

Sounds like you my need a new Arduino (Genuino outside The US). They’re pretty cheap these days; especially if you pick up a clone*.

Hopefully inventables will get you sorted though.

*-not counterfeit…clones are perfectly legal under Arduino’s open hardware license as long as they don’t use Arduino trademarks or branding. In fact, Genuino is essentially that. It is the brand that, and cofounder Massimo Banzi, use to manufacture authentic boards outside The US due to a legal dispute over the name.

In Windows 7, Arduino setup uses \Windows\system32\DRIVERS\usbser.sys as the device driver for the Arduino on my machine.

I’m not sure if it makes a difference that you are using a different driver but you might check on it.

Try using the driver here:
C:\Program Files\Arduino\drivers

This directory has the Arduino .inf file which sets up the Arduino.

Just ran the install from that Arduino driver folder and it didn’t help. I was under the understanding that just by installing the Arduino IDE that the drivers get installed automatically.

The usbser.sys file is on my machine as well. (I’m on WIndows 10)

The fact that my PC doesn’t even show the COM line in device manager, I’d think that the problem isn’t with the drivers. Or am I looking at that wrong?

It could be the driver as that is what interfaces the hardware with the Operating System. No/Wrong driver = no device.

However, that doesn’t seem to be your problem. There are lots of people on the forum here that have had trouble getting Windows 10 and the X-carve hooked up. I don’t have Windows 10 so I can’t help out there.

You are correct. If you cannot get the Device Manager to see the Arduino on a serial port then nothing else will work either.

Yes, that should have worked.

I had that same issue the other day. After a full power discharge on the computer and unit it is now working again. I would happen to guess some type of static build up, at least for me.

I could understand it being a driver issue, but the fact that neither computer sees the Arduino definitely makes it seem like it’s a problem with the Uno itself.

Talked with support and a new Uno is on the way. I’ll update here with results.

I got my replacement Uno from Inventables today and BAM! It immediately worked on both the Mac & PC, so something was definitely cooked on my old one.

Just another example of their outstanding customer service!

Interesting, I have a similar issue where the com port shows up in device manager but easle cant see the x carve on that port.

It works fine however from my raspberry running grblweb